Bug 11550 - libstdc++ doesn't have compatibility library for x86; let me upgrade and break groff?
Summary: libstdc++ doesn't have compatibility library for x86; let me upgrade and brea...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libstdc++ (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-21 15:39 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:53:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-05-21 15:39:18 UTC
I installed libstdc++-2.95.3-0.20000517.  It doesn't include the
backward-compatibility library libstdc++-libc6.1-2.so.3 for x86, although
there's code in the spec file which seems to try to install it (at least
for sparc).  It should be included for x86 too.

I was able to install this upgrade even though groff-1.15-9 requires
libstdc++-libc6.1-2.so.3.  I do not understand why I was allowed to install
this upgrade; shouldn't rpm have informed me that the upgrade would erase a
library which another installed package depends upon?

Comment 1 Cristian Gafton 2000-05-22 14:53:59 UTC
assign to jakub

Comment 2 Jakub Jelinek 2000-09-05 08:42:20 UTC
This has been fixed since then, there are compat-libstdc++ and libstdc++
as separated packages


Note You need to log in before you can comment on or make changes to this bug.