Bug 115500 - bug in gdm/xfce integration: xmodmap is run twice
bug in gdm/xfce integration: xmodmap is run twice
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce-utils (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 21:10 EST by Andrew J. Schorr
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 11:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew J. Schorr 2004-02-12 21:10:11 EST
Description of problem:
The problem is that when you login to an Xfce session from
gdm, xmodmap is run twice if the user has a $HOME/.Xmodmap
file.  This is because gdm first runs xmodmap, and then
/usr/share/xsessions/xfce.desktop directs gdm to invoke
startxfce4 which calls /etc/xfce4/xinitrc which then
runs xmodmap again.

Version-Release number of selected component (if applicable):
xfce-utils-4.0.3

How reproducible:
login to an Xfce session from gdm with a $HOME/.Xmodmap file

Steps to Reproduce:
1. create a $HOME/.Xmodmap file that will give bad results if
run more than once
2. login to an Xfce session through gdm
3. notice that the keyboard mapping is messed up
  
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2004-07-19 11:42:23 EDT
it's fixed in 4.0.6-1. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.