Bug 1155009 - Validation failure while editing host in production only environment
Summary: Validation failure while editing host in production only environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-21 08:56 UTC by Imre Farkas
Modified: 2016-09-20 05:03 UTC (History)
6 users (show)

Fixed In Version: foreman-1.6.0.44-6.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Imre Farkas 2014-10-21 08:56:54 UTC
Description of problem:
A "Please fill out this field." message appears around the browser without any help what is actually missing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to hosts#edit
2. Submit the form

Actual results:
"Please fill out this field." message appears.

Expected results:
The form should be submitted without any validation failure.


Additional info:

Comment 1 Imre Farkas 2014-10-21 08:58:41 UTC
I suspect that the following commit is missing from rhelosp-foreman:

commit 22438bd257ba586e92ecbccc8382511dabddbe26
Author: Marek Hulan <mhulan@redhat.com>
Date:   Fri Sep 26 10:24:36 2014 +0200

    Fixes #7750 - hidden required fields do not prevent submit
    
    When a field is explicitly required an HTML5 tag required was added
    which caused issues during form submit.

Comment 4 Mike Burns 2014-10-21 12:28:26 UTC
the patch in comment 1 also requires:

commit 3b87444aac04cf78e073bcb6e7f7778ef72f9c8e
Author: Marek Hulan <mhulan@redhat.com>
Date:   Tue Sep 16 11:09:12 2014 +0200

    Fixes #7450 - do not mark non-required fields
    
    If validation is conditional we don't mark fields as required by
    default. Also fixes disabling by override using :required option.

which requires:

commit 2af7c64a3b9c2699a3131483bc2344b50c138542
Author: Joseph Magen <jmagen@redhat.com>
Date:   Thu Jun 26 11:11:31 2014 +0300

    Fixes #6400 - Show * next to required form fields


---

backporting all 3 to foreman

Comment 6 Alexander Chuzhoy 2014-10-21 14:25:34 UTC
Verified:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.7-1.el6ost.noarch

Doesn't reproduce now.

Comment 10 errata-xmlrpc 2014-11-04 17:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.