Bug 1155014 - DeviceCreateError: ("'NoneType' object has no attribute 'name'", 'fedora-pool00')
Summary: DeviceCreateError: ("'NoneType' object has no attribute 'name'", 'fedora-pool...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a9b3b51d8c77bcd2299aae894af...
Keywords:
: 1155981 (view as bug list)
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-10-21 09:11 UTC by Vratislav Podzimek
Modified: 2014-10-31 02:42 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-28 23:07:05 UTC


Attachments (Terms of Use)
File: anaconda-tb (379.26 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: anaconda.log (23.62 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: environ (459 bytes, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: lsblk_output (1.53 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: nmcli_dev_list (1.01 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: os_info (377 bytes, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: program.log (27.41 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: storage.log (157.65 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: syslog (60.37 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: ifcfg.log (1.39 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details
File: packaging.log (44.92 KB, text/plain)
2014-10-21 09:11 UTC, Vratislav Podzimek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1157864 None None None Never

Internal Trackers: 1157864

Description Vratislav Podzimek 2014-10-21 09:11:15 UTC
Description of problem:
Tried to do LVM Thin Provisioning automated partitioning.

Version-Release number of selected component:
anaconda-21.48.8-1

The following was filed automatically by anaconda:
anaconda 21.48.8-1 exception report
Traceback (most recent call first):
  File "/tmp/updates/blivet/devices.py", line 924, in create
    raise errors.DeviceCreateError(str(e), self.name)
  File "/tmp/updates/blivet/deviceaction.py", line 294, in execute
    self.device.create()
  File "/tmp/updates/blivet/devicetree.py", line 361, in processActions
    action.execute(callbacks)
  File "/tmp/updates/blivet/__init__.py", line 364, in doIt
    self.devicetree.processActions(callbacks)
  File "/tmp/updates/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/tmp/updates/pyanaconda/install.py", line 189, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceCreateError: ("'NoneType' object has no attribute 'name'", 'fedora-pool00')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   root=live:http://192.168.100.1/virtuals/squashfs_f21.img inst.geoloc=0 nokill updates=http://192.168.100.1/virtuals/f21_updates.img inst.kdump_addon=on #ks=http://192.168.100.1/virtuals/ks_enc_autopart.cfg
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.0-301.fc21.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Vratislav Podzimek 2014-10-21 09:11:21 UTC
Created attachment 948855 [details]
File: anaconda-tb

Comment 2 Vratislav Podzimek 2014-10-21 09:11:24 UTC
Created attachment 948856 [details]
File: anaconda.log

Comment 3 Vratislav Podzimek 2014-10-21 09:11:26 UTC
Created attachment 948857 [details]
File: environ

Comment 4 Vratislav Podzimek 2014-10-21 09:11:28 UTC
Created attachment 948858 [details]
File: lsblk_output

Comment 5 Vratislav Podzimek 2014-10-21 09:11:30 UTC
Created attachment 948859 [details]
File: nmcli_dev_list

Comment 6 Vratislav Podzimek 2014-10-21 09:11:32 UTC
Created attachment 948860 [details]
File: os_info

Comment 7 Vratislav Podzimek 2014-10-21 09:11:34 UTC
Created attachment 948861 [details]
File: program.log

Comment 8 Vratislav Podzimek 2014-10-21 09:11:38 UTC
Created attachment 948862 [details]
File: storage.log

Comment 9 Vratislav Podzimek 2014-10-21 09:11:41 UTC
Created attachment 948863 [details]
File: syslog

Comment 10 Vratislav Podzimek 2014-10-21 09:11:43 UTC
Created attachment 948864 [details]
File: ifcfg.log

Comment 11 Vratislav Podzimek 2014-10-21 09:11:46 UTC
Created attachment 948865 [details]
File: packaging.log

Comment 12 Fedora Blocker Bugs Application 2014-10-21 09:26:37 UTC
Proposed as a Blocker for 21-beta by Fedora user vpodzime using the blocker tracking app because:

 When using the guided partitioning flow, the installer must be able to:

* Cleanly install to a disk with a valid ms-dos or gpt disk label and partition table which contains existing data and sufficient unpartitioned space for a Fedora installation
* Complete an installation using any combination of disk configuration options it allows the user to select

Comment 13 Mike Ruckman 2014-10-22 15:52:14 UTC
Confirmed this on TC4 WS in a VM.

Comment 14 Adam Williamson 2014-10-22 16:36:00 UTC
Discussed at 2014-10-22 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-22/f21-blocker-review.2014-10-22-16.03.log.txt . Accepted as a blocker per Beta criterion https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Custom_partitioning : "When using the custom partitioning flow, the installer must be able to: Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"

Comment 15 Vratislav Podzimek 2014-10-23 10:49:04 UTC
*** Bug 1155981 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2014-10-23 14:16:58 UTC
anaconda-21.48.12-1.fc21, python-blivet-0.61.7-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.7-1.fc21,anaconda-21.48.12-1.fc21

Comment 17 Fedora Update System 2014-10-23 16:21:54 UTC
Package anaconda-21.48.12-1.fc21, python-blivet-0.61.7-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.12-1.fc21 python-blivet-0.61.7-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13542/python-blivet-0.61.7-1.fc21,anaconda-21.48.12-1.fc21
then log in and leave karma (feedback).

Comment 18 Adam Williamson 2014-10-27 18:09:37 UTC
confirmed successful install to and boot from LVM thinp with Beta RC1, marking VERIFIED.

Comment 19 Adam Williamson 2014-10-27 23:29:03 UTC
Though note, 21 Beta RC1 installer crashes when you boot it on a system whose disk contains a thinp install:

https://bugzilla.redhat.com/show_bug.cgi?id=1157864

Comment 20 Fedora Update System 2014-10-28 18:17:54 UTC
anaconda-21.48.13-1.fc21, python-blivet-0.61.8-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.8-1.fc21,anaconda-21.48.13-1.fc21

Comment 21 Fedora Update System 2014-10-28 23:07:05 UTC
anaconda-21.48.12-1.fc21, python-blivet-0.61.7-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-10-31 02:42:52 UTC
anaconda-21.48.13-1.fc21, python-blivet-0.61.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.