Bug 115502 - Nautilus now shows only a folder/file window with no tree view available - crashes from CLI
Nautilus now shows only a folder/file window with no tree view available - cr...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 21:46 EST by Gerry Tool
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: nautilus-2.5.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 11:08:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2004-02-12 21:46:31 EST
Description of problem: Nautilus now shows only a folder/file window
with no tree view available.  It also crashes when executed from the CLI:
[gerry@gstpc gerry]$ nautilus
 
** ERROR **: file orbit-object.c: line 149 (do_unref): assertion
failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
aborting...
[gerry@gstpc gerry]$

Selecting an item in the window opens yet another window, ad infinitum
so one ends up with many open windows.

Version-Release number of selected component (if applicable):
nautilus-2.5.6-1

How reproducible:
Always

Steps to Reproduce:
1.Click on Home directory icon or enter nautilus at CLI
2.
3.
  
Actual results: Icon opens window with folders/files, but no tree view
for navigation to other locations.

CLI execution of nautilus crashes.

Expected results: The window should have a navigational capability and
there should be a way to reuse the window for the next level when an
item is clicked, so that multiple windows do not clutter the desktop.


Additional info:
Comment 1 sangu 2004-02-12 23:24:22 EST
please see slso : http://bugzilla.gnome.org/show_bug.cgi?id=134178

modified location="/usr/libexec/gnome-vfs-daemon"

http://cvs.gnome.org/bonsai/cvsblame.cgi?file=gnome-vfs%2Fdaemon/Makefile.am&rev=&root=/cvs/gnome

file bug.
Comment 2 Alexander Larsson 2004-02-13 03:00:53 EST
The window changes are intentional. 

I wonder if the crash is on shutdown. When you launched it, was a copy
of nautilus already running?
Comment 3 Gerry Tool 2004-02-13 09:28:33 EST
A nautilus window is actually opened showing my home directory.

In addition, an error window appears with the contents:

Application "nautilus" (process 3517) has crashed
due to a fatal error.
(Trace/breakpoint trap)

and a command line error appears:

[gerry@gstpc gerry]$ nautilus &
[1] 3517
[gerry@gstpc gerry]$
** ERROR **: file orbit-object.c: line 149 (do_unref): assertion
failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
aborting...

The nautilus window remains open.
Comment 4 Gerry Tool 2004-02-13 11:08:16 EST
This is fixed in nautilus-2.5.7-1.

As far as I'm concerned the bug can be closed
Comment 5 Aaron Kurtz 2004-02-14 17:42:25 EST
I've upgraded to nautilus-2.5.7-1 from rawhide and I'm still seeing
the crash when nautilus is started from a console.

[test@rydia test]$ nautilus --version
 
(nautilus:2356): GLib-CRITICAL **: file gstrfuncs.c: line 2129
(g_strsplit): assertion `string != NULL' failed
 
(nautilus:2356): GLib-CRITICAL **: file gstrfuncs.c: line 2241
(g_strjoinv): assertion `str_array != NULL' failed
Gnome nautilus 2.5.7
[test@rydia test]$ nautilus
 
(nautilus:2342): GLib-CRITICAL **: file gstrfuncs.c: line 2129
(g_strsplit): assertion `string != NULL' failed
 
(nautilus:2342): GLib-CRITICAL **: file gstrfuncs.c: line 2241
(g_strjoinv): assertion `str_array != NULL' failed
 
** ERROR **: file orbit-object.c: line 149 (do_unref): assertion
failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
aborting...
 
(gnome_segv2:2352): GLib-CRITICAL **: file gstrfuncs.c: line 2129
(g_strsplit): assertion `string != NULL' failed
 
(gnome_segv2:2352): GLib-CRITICAL **: file gstrfuncs.c: line 2241
(g_strjoinv): assertion `str_array != NULL' failed

I notice the previous Nautilus style is still available through
"nautilus --browser" for those who want it.
Comment 6 Alexander Larsson 2004-02-17 04:02:30 EST
The bug could also be in ORBit2 or libbonobo*. Try updating them.

Note You need to log in before you can comment on or make changes to this bug.