Bug 1155060 - automatically configured iptables doesn't allow communication of engine with reports
Summary: automatically configured iptables doesn't allow communication of engine with ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-21 10:40 UTC by movciari
Modified: 2014-12-04 15:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-27 14:53:05 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description movciari 2014-10-21 10:40:43 UTC
Description of problem:
when i let engine-setup configure iptables automatically, dashboard tab in webadmin is empty, it starts working after i flush iptables

Version-Release number of selected component (if applicable):
vt6

How reproducible:
always

Steps to Reproduce:
1. yum install -y rhevm-setup rhevm-dwh-setup rhevm-reports-setup
2. allow setup to configure iptables automatically
3. go to webadmin dashboard tab - it will be empty
4. flush iptables
5. go to webadmin dashboard tab - dashboard will show up

Actual results:
iptables doesn't allow engine to communicate with reports

Expected results:
iptables should allow engine to communicate with reports

Additional info:
for good security, it should probably be set to allow communication with reports only when reports are installed, but it should work for remote reports installation, too, or at least instruct admin how to set iptables correctly when installing reports

Comment 2 Yedidyah Bar David 2014-10-21 12:03:19 UTC
(In reply to movciari from comment #0)
> Description of problem:
> when i let engine-setup configure iptables automatically, dashboard tab in
> webadmin is empty, it starts working after i flush iptables

> 
> Version-Release number of selected component (if applicable):
> vt6
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. yum install -y rhevm-setup rhevm-dwh-setup rhevm-reports-setup
> 2. allow setup to configure iptables automatically
> 3. go to webadmin dashboard tab - it will be empty
> 4. flush iptables
> 5. go to webadmin dashboard tab - dashboard will show up

Sounds weird. All on same machine? How is iptables relevant?
Are you sure that this was broken by iptables? I.e. did you try to enable iptables and see that it's broken again?

Comment 3 movciari 2014-10-27 10:15:11 UTC
yes, when i restart iptables to enable firewall again, dashboard tab in webadmin is broken again

Comment 5 movciari 2014-10-27 14:10:29 UTC
i realized that machine was still on vt5, upgraded it and now i can't reproduce again


Note You need to log in before you can comment on or make changes to this bug.