This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 115519 - Mail delivery crashed with ValueError: Empty module name
Mail delivery crashed with ValueError: Empty module name
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 02:28 EST by Philipp Hügelmeyer
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 05:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Hügelmeyer 2004-02-13 02:28:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040116

Description of problem:


Version-Release number of selected component (if applicable):
mailman-2.1.1-5

How reproducible:
Sometimes

Steps to Reproduce:
1. Send a mail to a mailing list.

Actual Results:  From: /var/log/mailman/error

Feb 12 15:25:47 2004 (17384) SHUNTING:
1076595946.8666761+aaf6d6925aa30c71b4bafaFeb 12 15:35:09 2004 (17726)
Uncaught runner exception: Empty module name
Feb 12 15:35:09 2004 (17726) Traceback (most recent call last):
  File "/var/mailman/Mailman/Queue/Runner.py", line 105, in _oneloop
    self._onefile(msg, msgdata)
  File "/var/mailman/Mailman/Queue/Runner.py", line 155, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/var/mailman/Mailman/Queue/IncomingRunner.py", line 130, in
_dispose
    more = self._dopipeline(mlist, msg, msgdata, pipeline)
  File "/var/mailman/Mailman/Queue/IncomingRunner.py", line 153, in
_dopipeline
    sys.modules[modname].process(mlist, msg, msgdata)
  File "/var/mailman/Mailman/Handlers/ToDigest.py", line 82, in process
    send_digests(mlist, mboxfp)
  File "/var/mailman/Mailman/Handlers/ToDigest.py", line 123, in
send_digests
    send_i18n_digests(mlist, mboxfp)
  File "/var/mailman/Mailman/Handlers/ToDigest.py", line 295, in
send_i18n_diges    msg = scrubber(mlist, msg)
  File "/var/mailman/Mailman/Handlers/Scrubber.py", line 308, in process
    t = t.encode(charset, 'replace')
  File "/usr/lib/python2.2/encodings/__init__.py", line 51, in
search_function
    mod = __import__(modname,globals(),locals(),'*')
ValueError: Empty module name


Expected Results:  Mail should be delivered to mailing list.

Additional info:

It looks like bug is known to upstream. please fix it.
http://www.mail-archive.com/mailman-developers@python.org/msg06317.html

Note You need to log in before you can comment on or make changes to this bug.