Bug 115523 - xmms segfault on startup
Summary: xmms segfault on startup
Status: CLOSED DUPLICATE of bug 112864
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 08:55 UTC by Noa Resare
Modified: 2014-03-17 02:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noa Resare 2004-02-13 08:55:28 UTC
Description of problem:

xmms segfaults very early on in the startup process on a vanilla 1.90
box. 

Version-Release number of selected component (if applicable):
xmms-1.2.9-2.p

How reproducible:
always

Steps to Reproduce:
1. try to start 'xmms' from the command line
2. a nice friendly localized message saying "Segmentation fault, file
a bug in http://bugs.xmms.org" 


Additional info:

gdb backtrace is very short: 

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1207774112 (LWP 18492)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()

Comment 1 Noa Resare 2004-02-13 09:12:10 UTC
I just noted that to trigger this the $HOME/.xmms folder needs to be
missing. When I restored my old $HOME the problem went away. To
trigger it again i needed to rename my .xmms directory.

Comment 2 Noa Resare 2004-02-13 12:01:48 UTC
Some shotgun recompiling shows that if i exclude the arts
(xmms-1.2.8-arts.patch) patch from the rpm this fixes the segfault. 

Since I don't use arts I won't try to debug this any further :)

Comment 3 Bill Nottingham 2004-02-13 20:41:32 UTC

*** This bug has been marked as a duplicate of 112864 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.