Bug 1155362 (CVE-2014-8326) - CVE-2014-8326 phpmyadmin: cross-site scripting (XSS) flaw fixed in versions 4.0.10.5, 4.1.14.6, and 4.2.10.1 (PMASA-2014-12)
Summary: CVE-2014-8326 phpmyadmin: cross-site scripting (XSS) flaw fixed in versions 4...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2014-8326
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1155363 1155364 1155365 1155366 1155367 1155368
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-22 02:34 UTC by Murray McAllister
Modified: 2019-09-29 13:23 UTC (History)
11 users (show)

Fixed In Version: phpMyAdmin 4.0.10.5, phpMyAdmin 4.1.14.6, phpMyAdmin 4.2.10.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-05 17:00:53 UTC


Attachments (Terms of Use)

Description Murray McAllister 2014-10-22 02:34:43 UTC
The 4.0.10.5, 4.1.14.6, and 4.2.10.1 releases of phpMyAdmin fix a cross-site scripting (XSS) flaw in the SQL debug output:

""
With a crafted database or table name it is possible to trigger an XSS in SQL debug output when enabled and in server monitor page when viewing and analysing executed queries.
""

As noted in the upstream advisory, this issue can only be triggered by logged-in users.

References:

http://www.phpmyadmin.net/home_page/security/PMASA-2014-12.php

Comment 2 Murray McAllister 2014-10-22 02:35:56 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1155363]
Affects: epel-5 [bug 1155364]
Affects: epel-6 [bug 1155366]
Affects: epel-7 [bug 1155367]

Comment 3 Murray McAllister 2014-10-22 02:35:59 UTC
Created phpMyAdmin3 tracking bugs for this issue:

Affects: epel-5 [bug 1155365]

Comment 4 Fedora Update System 2014-10-28 06:34:55 UTC
phpMyAdmin-4.2.10.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-11-01 01:45:06 UTC
phpMyAdmin-4.2.10.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-11-01 17:14:35 UTC
phpMyAdmin-4.2.10.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-11-05 00:21:14 UTC
phpMyAdmin-4.0.10.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-11-09 15:43:28 UTC
phpMyAdmin-4.2.10.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-11-12 23:15:02 UTC
phpMyAdmin4-4.0.10.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.