Bug 115549 - RFE: rpm needs a full blown depsolver to select pkgs from args
RFE: rpm needs a full blown depsolver to select pkgs from args
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 09:45 EST by Toralf
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 09:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2004-02-13 09:45:14 EST
Description of problem:
This has been discussed on the mailing list before:
It would be really nice to be able to send rpm a long list of packages
without checking if all of them are actually installable, and get it
to ignore packages that are already present or have missing
dependencies etc., and install the ones that may safely be installed.
- instead of having the entire install fail in the situation where
there are uninstallable packages.

Similiarily for removals, it would be useful to be able to say

rpm -e <long list of packages>

and have (only) some of the packages removed, but others kept because
they are required by installed rpms not included in the list.


Version-Release number of selected component (if applicable):
4.2-1
Comment 1 Leonard den Ottolander 2004-03-22 13:50:25 EST
"rpm -U --aid" should install non existent packages with dependencies
and ignore/upgrade already present packages.

"rpm -e" already works as you suggest. You need to specify --nodeps
for it to remove packages that are needed by other packages.

If there is anything you want that is not covered by the above remarks
then please let us know. Otherwise I would say NOTABUG.
Comment 2 Toralf 2004-03-24 04:52:21 EST
No, I think --aid does something else entirely - I'm talking about
selection between packages specified on the command line, not
automatic dependency resolution. Also, as far as I can tell you are
wrong about '-e'.

Consider the following tests. In the first, I wanted rpm -U to install
ogle-devel, and simply ignore ogle (which is installed already.) In
the second, galeon (which isn't required by anything) should be
removed, and kernel kept, if 'rpm -e' worked as implied above. In both
cases, nothing is changed.


# rpm -q ogle ogle-devel
ogle-0.9.2-ogle1
package ogle-devel is not installed
# rpm --Uvh ogle-0.9.2-ogle1.i686.rpm ogle-devel-0.9.2-ogle1.i686.rpm
--aid
Preparing...               
########################################### [100%]
        package ogle-0.9.2-ogle1 is already installed
# rpm -q ogle ogle-devel
ogle-0.9.2-ogle1
package ogle-devel is not installed


# rpm -e galeon kernel
error: Failed dependencies:
        kernel >= 2.4.0 is needed by (installed) sndconfig-0.70-2
        kernel = 2.4.20-8 is needed by (installed)
kernel-module-alsa-0.9.3a-fr1_2.4.20_8
        kernel > 2.2.0 is needed by (installed) NVIDIA_GLX-1.0-4363
        kernel >= 2.4.20 is needed by (installed) iptables-1.2.8-13
        kernel >= 2.2.0 is needed by (installed) libpcap-0.7.2-7.1
        kernel >= 2.2 is needed by (installed) pciutils-2.1.10-8
        kernel >= 2.2.14 is needed by (installed) nfs-utils-1.0.6-1
        kernel >= 2.4 is needed by (installed) quota-3.06-11
        kernel >= 2.2.9 is needed by (installed) rp-pppoe-3.5-8
        kernel >= 2.2.0 is needed by (installed) tcpdump-3.7.2-7.1
        kernel >= 2.0.36 is needed by (installed) shapecfg-2.2.12-14
        kernel >= 2.2.16-21 is needed by (installed) sysstat-4.0.7-5
        kernel >= 2.2.0 is needed by (installed)
NVIDIA_kernel-1.0-4363_2.4.22_1.2115.nptl
        kernel-drm = 4.3.0 is needed by (installed) XFree86-4.3.0-42
# rpm -q galeon kernel
galeon-1.2.7-3
kernel-2.4.22-1.2115.nptl
Comment 3 Jeff Johnson 2005-02-07 17:18:26 EST
Retooling this bug as an RFE for a rpmlib dependency solver ...
Comment 4 Paul Nasrat 2005-11-28 18:40:06 EST
Red Hat Linux 9 is no longer supported. Dependency solving in Fedora is provided
by yum.
Comment 5 Toralf 2005-11-29 03:18:50 EST
I'm not sure yum resolves dependencies in the way discussed here. It resolves
them via "repository" setup, this is about installation via rpm files. Last time
I checked, yum didn't support this mode of operation at all. Also this is not a
specific to Red Hat 9 => reopening as Fedora Core 4 bug.
Comment 6 Toralf 2005-11-29 03:25:18 EST
Oh, and the report is not originally about resolving deps. It's about ignoring
packages that have unresolvable ones (on installation) or that would break
dependencies (on removal). Not quite the same thing. And it's about ignoring
already-installed packages, too, which is something else entirely.
Comment 7 Paul Nasrat 2005-11-29 09:29:47 EST
yum supports installing from files.

There are no plans at the current time to add the functionality you ask for.

Note You need to log in before you can comment on or make changes to this bug.