Bug 1155576 - TypeError: must be string, not None
Summary: TypeError: must be string, not None
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e4b080cab8e59417875e3a8d186...
Keywords:
Depends On:
Blocks: F21BetaFreezeException F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-10-22 12:15 UTC by Vít Ondruch
Modified: 2014-10-31 02:42 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-31 02:42:37 UTC


Attachments (Terms of Use)
File: anaconda-tb (921.28 KB, text/plain)
2014-10-22 12:15 UTC, Vít Ondruch
no flags Details
File: anaconda.log (23.90 KB, text/plain)
2014-10-22 12:15 UTC, Vít Ondruch
no flags Details
File: environ (492 bytes, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: lsblk_output (2.27 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: nmcli_dev_list (1.68 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: os_info (377 bytes, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: program.log (86.64 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: storage.log (106.32 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: syslog (73.96 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: ifcfg.log (1.39 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details
File: packaging.log (541.29 KB, text/plain)
2014-10-22 12:16 UTC, Vít Ondruch
no flags Details

Description Vít Ondruch 2014-10-22 12:15:35 UTC
Version-Release number of selected component:
anaconda-21.48.9-1

The following was filed automatically by anaconda:
anaconda 21.48.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/crypt.py", line 55, in crypt
    return _crypt.crypt(word, salt)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/users.py", line 120, in cryptPassword
    return crypt.crypt (password, saltstr)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/users.py", line 408, in setUserPassword
    self.admin.setpassUser(user, cryptPassword(password, algo=algo), True)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/users.py", line 417, in setRootPassword
    return self.setUserPassword("root", password, isCrypted, isLocked, algo)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1466, in execute
    users.setRootPassword(self.password, self.isCrypted, self.lock, algo)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 96, in doConfiguration
    ksdata.rootpw.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: must be string, not None

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/linux/development/21/x86_64/os/ initrd=F21/latest/x86_64/initrd.img BOOT_IMAGE=F21/latest/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.0-301.fc21.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Vít Ondruch 2014-10-22 12:15:57 UTC
Created attachment 949360 [details]
File: anaconda-tb

Comment 2 Vít Ondruch 2014-10-22 12:15:59 UTC
Created attachment 949361 [details]
File: anaconda.log

Comment 3 Vít Ondruch 2014-10-22 12:16:00 UTC
Created attachment 949362 [details]
File: environ

Comment 4 Vít Ondruch 2014-10-22 12:16:01 UTC
Created attachment 949363 [details]
File: lsblk_output

Comment 5 Vít Ondruch 2014-10-22 12:16:03 UTC
Created attachment 949364 [details]
File: nmcli_dev_list

Comment 6 Vít Ondruch 2014-10-22 12:16:04 UTC
Created attachment 949365 [details]
File: os_info

Comment 7 Vít Ondruch 2014-10-22 12:16:06 UTC
Created attachment 949366 [details]
File: program.log

Comment 8 Vít Ondruch 2014-10-22 12:16:09 UTC
Created attachment 949367 [details]
File: storage.log

Comment 9 Vít Ondruch 2014-10-22 12:16:12 UTC
Created attachment 949368 [details]
File: syslog

Comment 10 Vít Ondruch 2014-10-22 12:16:14 UTC
Created attachment 949369 [details]
File: ifcfg.log

Comment 11 Vít Ondruch 2014-10-22 12:16:26 UTC
Created attachment 949370 [details]
File: packaging.log

Comment 12 David Shea 2014-10-23 18:15:18 UTC
Can you describe the steps you took to reach this bug? Did you set a password? Did you create a user? Did you re-enter either the user or root password spokes?

Comment 13 Vít Ondruch 2014-10-24 08:01:33 UTC
I don't remember exactly, but I first tried to enter root password, then I decided not to enter it, so I deleted the password, got back and then created user to be able to move forward with the installation. But that did not work due to this bug.

Comment 14 Josef Skladanka 2014-10-24 08:34:57 UTC
Another user experienced a similar problem:

Installed from the Live ISO (Beta RC1), let the installation finish without setting a password.
Then created an user account with administrator rights (no root password), and clicked "Finish Confiugration"

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
other involved packages: python-libs-2.7.8-4.1.fc21.x86_64
package:        anaconda-core-21.48.12-1.fc21.x86_64
product:        Fedora"
reason:         TypeError: must be string, not None
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 15 Josef Skladanka 2014-10-24 09:00:09 UTC
This can be always reproduced by:

1. Boot Fedora Beta RC1 Workstation Live
2. Lett the installation "Finish" without entering either the root password or creating an user account
3. Create the user (without administrator rights)
4. Enter the "Set root password" screen, do not fill anything, and return back
5. Tick the "Make this user an administrator"
6. Hit "Finish Configuration"

I suspect that just the fact of entering the root-password spoke without setting it causes the issue, but I need to do more testing.

Comment 16 Josef Skladanka 2014-10-24 09:19:53 UTC
Update of previous comment:

No need to visit the "User Creation" spoke twice, just create an user with admin rights, visit the "Root Password" spoke without setting any, and hit "Finish Configuration".

For me, this reproduces the bug every time.

Comment 17 Fedora Blocker Bugs Application 2014-10-24 09:25:44 UTC
Proposed as a Blocker for 21-alpha by Fedora user jskladan using the blocker tracking app because:

 adamw: i'd just call it a conditional violation of one of the really basic alpha criteria:

"When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."
or possibly
 "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system. "

Flagging for discussion

Comment 18 Adam Williamson 2014-10-24 10:44:59 UTC
Correcting milestone (someone needs to update blockerbugs, guys)

Comment 19 Adam Williamson 2014-10-24 17:23:50 UTC
Discussed at 2014-10-24 Go/No-Go meeting: http://meetbot.fedoraproject.org/fedora-meeting-2/2014-10-24/f21_beta_gono-go_meeting.2014-10-24-17.01.log.txt . This is a conditional violation, so we had to make a subjective call on how 'serious' it is. We agreed it's not quite bad enough to block Beta, but should block Final - this is the kind of 'unexpected case' bug that's reasonable to fix up between Beta and Final releases. But it's accepted as a freeze exception for Beta, and it'd be very good to get it fixed if we slip the release and have time to fix it.

Comment 20 Fedora Update System 2014-10-28 18:15:29 UTC
anaconda-21.48.13-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.13-1.fc21

Comment 21 Fedora Update System 2014-10-31 02:42:37 UTC
anaconda-21.48.13-1.fc21, python-blivet-0.61.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.