Bug 115558 - XMMS does not properly draw focus when playlist or equalizer is clicked
XMMS does not properly draw focus when playlist or equalizer is clicked
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 10:42 EST by Kevin Gottsman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 22:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Gottsman 2004-02-13 10:42:46 EST
Description of problem: XMMS should draw complete focus (or bring to
top) when playlist or equalizer is clicked 


Version-Release number of selected component (if applicable): Multiple
versions... Currently using XMMS 1.2.8


How reproducible: Every time


Steps to Reproduce:
1. Turn on playlist and equalizer. arrange so that it looks like a
standard winamp configuration. Player on top, eq on bottom, playlist
on right
2. Bring a window on top of a portion of the player
3. Click on the equalizer or the playlist
  
Actual results: If playlist clicked, only that component draws focus.
Other components are left behind window. If the main player is
clicked, then all windows draw focus.


Expected results: Entire XMMS application brought to front. I was
playing with Knoppix and it did work correctly


Additional info: Currently using the Smokey Blue theme.
Comment 1 Bill Nottingham 2004-02-13 15:34:44 EST
When it 'worked correctly', what windowmanager were you using; what
are you using now?
Comment 2 Kevin Gottsman 2004-02-23 15:27:46 EST
I am using the standard window manager for Fedora. I believe that its
metacity but not 100% sure.

For knoppix, I think its Kwin. Knoppix defaults to the KDE environment.

Hope this helps.
Comment 3 Bill Nottingham 2004-02-23 15:40:10 EST
Havoc: what needs to be done here?
Comment 4 Colin Walters 2004-09-21 22:38:27 EDT
This works for me with the latest metacity and xmms.

Note You need to log in before you can comment on or make changes to this bug.