Bug 115564 - FC2 test1 install won't work with lvm on non-partitioned hard disk
FC2 test1 install won't work with lvm on non-partitioned hard disk
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-02-13 11:02 EST by Andreas Müller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-29 12:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda dump (63.88 KB, text/plain)
2004-02-13 11:04 EST, Andreas Müller
no flags Details

  None (edit)
Description Andreas Müller 2004-02-13 11:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I have my /home partition on lvm1. The first physical volume of the
volume group is on partition /dev/hda4, the second one on /dev/hdb.
Note that I really mean the entire disk, there is no partition table
on /dev/hdb. This worked with FC1.

When trying to upgrade to FC2 test1, the installer says that it cannot
find a partition table on /dev/hdb (that's correct) an asked me if it
should setup one or leave the disk alone. I've chosen the second
option. In the next step, the installer hangs, see attachment.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Setup FC1 with lvm on entire disk.
2. Upgrade to FC2 test1.

Actual Results:  The installer hangs, see attachment.

Expected Results:  I don't think that using lvm on an entire disk is
supported, but anaconda shouldn't crash if I have such a
constellation. I would be nice if such things could be detected (as
the lvm tools correctly detected my volume group) in future releases.

Additional info:
Comment 1 Andreas Müller 2004-02-13 11:04:10 EST
Created attachment 97649 [details]
anaconda dump
Comment 2 Andreas Müller 2004-02-13 11:07:06 EST
Oh, typo in the last sentence: s/I would be nice/It would be nice/

Comment 3 Jeremy Katz 2004-02-17 19:37:33 EST
It's not supported (loss of the partition table information makes it
really difficult to do sane things and also leads to problems in a lot
of cases and so is highly not recommended).  But I've fixed the traceback
Comment 4 Andreas Müller 2004-03-29 12:44:17 EST
OK, tested with FC2test2, works now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.