Bug 1155703 - Add API call for SSL_VersionRangeSet (rebase)
Summary: Add API call for SSL_VersionRangeSet (rebase)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-nss
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: John Dennis
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On: 1154776
Blocks: 1156466
TreeView+ depends on / blocked
 
Reported: 2014-10-22 16:29 UTC by John Dennis
Modified: 2015-03-05 10:26 UTC (History)
6 users (show)

Fixed In Version: python-nss-0.16.0-2.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of: 1154776
Environment:
Last Closed: 2015-03-05 10:26:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0443 normal SHIPPED_LIVE python-nss bug fix and enhancement update 2015-03-05 15:05:15 UTC

Description John Dennis 2014-10-22 16:29:11 UTC
+++ This bug was initially created as a clone of Bug #1154776 +++

Description of problem:

The old protocol API for NSS allows only SSL2, SSL3 and TLS1.0. A new API was added to specify the min/max of the allowed range, SSL_VersionRangeSet. We need that in order to be able to enable the client to use TLS v1.1 and TLS v1.2

Version-Release number of selected component (if applicable):

python-nss-0.13-1.el6

How reproducible:


Steps to Reproduce:
1. Install IPA server
2. Update /etc/httpd/conf.d/nss.conf and set NSSProtocol to TLSv1.1
3. ipa -vv user-show admin

Actual results:

(SSL_ERROR_PROTOCOL_VERSION_ALERT) Peer reports incompatible or unsupported protocol version.

This is because only SSL3 and TLSv1 are enabled by default and there is no mechanism to enable them.

--- Additional comment from John Dennis on 2014-10-22 12:28:04 EDT ---

Rob, there is a Fedora scratch build here for a trial 0.16.0 version:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7930311

It includes all the SSL version range API calls (as well as the ability to set trust properites on Certificates that someone else had requested). Examples of using the SSL version range stuff can be found in doc/examples/ssl_version_range.py

I'd rather not go through the effort of doing an official Mozilla release and RHEL builds until you sanity check this trial version. Would you please do that and report back? Thanks!

Comment 8 errata-xmlrpc 2015-03-05 10:26:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0443.html


Note You need to log in before you can comment on or make changes to this bug.