Bug 1155770 - rubygem-staypuft: Selecting more than one Cinder driver backend doesn't set the "Multiple Backend" value to true.
Summary: rubygem-staypuft: Selecting more than one Cinder driver backend doesn't set t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: z2
: Installer
Assignee: Jiri Stransky
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-22 19:03 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:03 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.10-1.el6ost
Doc Type: Bug Fix
Doc Text:
The 'multiple_backends' parameter for Block Storage on High Availability (HA) controller host group was set to 'false'. As a result, when a user checked for more than one backend in the installer wizard, only single backend configuration would get deployed. With this update, the installer sets the 'multiple_backends' parameter to 'true' when more than one backend is checked in the configuration wizard. As a result, multiple Block Storage backends can be deployed with HA controller when using the installer wizard.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-22 19:03:01 UTC
rubygem-staypuft: Selecting more than one Cinder driver backend doesn't set the "Multiple Backend" value to true.

Environment:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch


Steps to reproduce:
1. Install rhel-osp-installer
2. Create an HAneutron deployment.
3. select NFS and ceph driver backends for Cinder.
4. Complete the deployment and go to the advanced configuration tab.
5. Select Cinder(HA) and check the "Multiple backends" value.

Result:
Multiple backends is set to false.

Expected result:
Should be set to true.

Comment 1 Jiri Stransky 2014-10-23 13:29:42 UTC
Pull request upstream:

https://github.com/theforeman/staypuft/pull/364

Comment 2 Jiri Stransky 2014-10-23 14:23:59 UTC
Merged.

Comment 4 Alexander Chuzhoy 2014-10-24 15:53:32 UTC
Verified:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
rhel-osp-installer-0.4.5-2.el6ost.noarch
openstack-puppet-modules-2014.1-24.1.el6ost.noarch
openstack-foreman-installer-2.0.31-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.10-1.el6ost.noarch


Selecting more than one Cinder driver backend sets the "Multiple Backend" value to true.

Comment 7 errata-xmlrpc 2014-11-04 17:03:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.