Bug 11559 - lots of Perl errors from gimp 1.1.22-1
lots of Perl errors from gimp 1.1.22-1
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gimp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-21 17:17 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-21 17:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-05-21 17:17:57 EDT
I get a whole bunch of Perl errors when I install and run gimp-1.1.22-1,
probably because Gimp is installing its .pm file in
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Gimp.pm, which is not where it
should be since I have perl-5.00503-10 installed (and indeed there is no
later version of Perl available as an RPM on ftp.redhat.com).

Gimp's installation shouldn't depend on the standard Perl header paths.
Gimp Perl files should be installed in a Gimp-specific directory, and the
Gimp Perl scripts and plugins should know to add that directory to @INC.

Either that, or the Gimp RPM installation scripts should know how to
determine the correct directory into which to install the files, e.g., by
running "perl -e '@SITEINC = grep(/site_perl/, @INC); print pop @SITEINC;'"
or something like that.
Comment 1 Matt Wilson 2001-01-26 21:04:18 EST
your perl needs to match the version of perl on the system for which those gimp
packages were made.

Note You need to log in before you can comment on or make changes to this bug.