Bug 115594 - if dovecot hangs, it cannot be restarted
Summary: if dovecot hangs, it cannot be restarted
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 18:31 UTC by Luigi Iotti
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 10:26:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luigi Iotti 2004-02-13 18:31:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; 
T312461)

Description of problem:
If for some reason dovecot daemon dies (for ex. is killed) the 
service can not be restarted by simply issuing 
service dovecot start
or
service dovecot restart

This behaviour is due to /etc/init.d/dovecot script, that checks the 
presence of the lock subsystem file. If present, the script does not 
restart the service, so I have to manually delete the lock file 
( /var/lock/subsys/dovecot )
I suggest to the maintainer of the package to apply the following 
patch that simply eliminates this check:

--- dovecot.bak 2003-09-23 18:05:20.000000000 +0200
+++ dovecot     2004-02-13 18:29:59.000000000 +0100
@@ -17,13 +17,11 @@
 
 start() {
        # Check if dovecot is already running
-       if [ ! -f /var/lock/subsys/dovecot ]; then
            echo -n $"Starting $prog: "
            daemon /usr/sbin/dovecot
            RETVAL=$?
            [ $RETVAL -eq 0 ] && touch /var/lock/subsys/dovecot
            echo
-       fi
 }
 
 stop() {


Version-Release number of selected component (if applicable):
dovecot-0.99.10-6

How reproducible:
Always

Steps to Reproduce:
1.service dovecot start
2.killall dovecot
3.service dovecot start
The dovecot service is not restarted
    

Additional info:

Comment 1 Jeremy Katz 2004-02-18 00:40:38 UTC
Fixed in next build


Note You need to log in before you can comment on or make changes to this bug.