Bug 1155957 - [3.5-7.0] USB Flash Drive install of rhevh7.0 created via dd fails into hosts
Summary: [3.5-7.0] USB Flash Drive install of rhevh7.0 created via dd fails into hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1167620
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-10-23 09:03 UTC by haiyang,dong
Modified: 2016-02-10 20:05 UTC (History)
12 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Known Issue
Doc Text:
Previously, a multipath regression caused machines to fail to boot USB media created using DD. This has now been corrected and the Hypervisor can be installed or reinstalled from USB media.
Clone Of:
Environment:
Last Closed: 2015-02-11 21:04:55 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached Screenshot for console screen.jpg (1.94 MB, image/jpeg)
2014-10-23 09:03 UTC, haiyang,dong
no flags Details
screen_output_log for comment 9 (191.44 KB, text/plain)
2014-12-02 12:30 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 35481 master ABANDONED Use nompath instead of rd_NO_MULTIPATH on EL7 Never
oVirt gerrit 35828 None None None Never

Description haiyang,dong 2014-10-23 09:03:53 UTC
Created attachment 949755 [details]
attached Screenshot for console screen.jpg

Description of problem:
Use dd to create the image
dd if=rhevh-7.0-20141006.0.el7ev.iso of=/dev/sdb

But using this USB media to install rhev-h 7.0 into hosts failed.(Seen console screen.jpg)

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

How reproducible:

100%

Steps to Reproduce:
1. Use DD to build Flash Driver
2. Boot from usb media and select install or Re-install hypervisor

Actual results:
Machine is left in an unbootable state

Expected results:
We should get the rhevh installer console.

Additional info:

Comment 1 Fabian Deutsch 2014-11-17 19:18:45 UTC
Bumping the priority, because this is one of the recommended ways (and easiest way) to create the USB boot media.

Comment 2 Ryan Barry 2014-11-17 22:51:43 UTC
Harald -

This appears to be a regression of bz#1034327 on EL7.

Multipath is grabbing some USB drives, and they can't be mounted. We're passing rd_NO_MULTIPATH (which looks odd on EL7 anyway), 90multipath/multipathd.sh doesn't appear to have a way to disable it on EL7. 

Can we get something similar to rd_NO_MULTIPATH (rd.multipath=<bool> ?) added to dracut on EL7, or is there a more canonical way to do this?

Comment 3 Ryan Barry 2014-11-18 17:48:39 UTC
Just as an aside, I also tested this against an image with the udev patch applied to EL7. Same result.

Comment 6 Fabian Deutsch 2014-11-26 10:57:19 UTC
The real problem here is multipath. We can not solve this in the scope of RHEV-H, but rely on fixes in device-mapper-multipath, see bug 1155957

Comment 7 Ying Cui 2014-11-26 11:14:08 UTC
(In reply to Fabian Deutsch from comment #6)
> The real problem here is multipath. We can not solve this in the scope of
> RHEV-H, but rely on fixes in device-mapper-multipath, see bug 1155957

See bug 1167620 in device-mapper-multipath component. Thanks.

Comment 10 Ying Cui 2014-12-02 12:30:17 UTC
Created attachment 963722 [details]
screen_output_log for comment 9

Comment 11 haiyang,dong 2014-12-04 02:29:05 UTC
Due to ycui has given test result for scratch build rhev-hypervisor7-7.0-20141201.0.iso in Comment 9, so i clean needinfo requests in here.

Comment 16 haiyang,dong 2015-01-13 09:10:19 UTC
Test version:
rhev-hypervisor7-7.0-20150112.0.el7ev
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el7.noarch

rhev-hypervisor6-6.6-20150112.0
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el6.noarch

Test steps:
1. Use DD to build Flash Driver
2. Boot from usb media and select install or Re-install hypervisor

After step2, Could get the rhevh installer console, and also reinstall the above two rhevh iso success.so changed the status into "VERIFIED".

Comment 18 errata-xmlrpc 2015-02-11 21:04:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.