Bug 115598 - DHCP fails when running FC2 Test1 kernel in VMware
DHCP fails when running FC2 Test1 kernel in VMware
Status: CLOSED DUPLICATE of bug 100527
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Barr
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 14:02 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-02-13 14:02:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
This bug is now known since ages as bug #100527, that's why I create a
new bug report for FC2 Test1.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to use DHCP when running FC2 Test1 in VMware
2.
3.
    

Additional info:
Comment 1 Thomas M Steenholdt 2004-02-18 10:32:51 EST
Did you try this on previous versions of RHL or Fedora?

They all seem to suffer from the same problem (actualy i think the
problem is with VMware which cannot pass link state on to the virtual
device)

Anyway, All I have ever had to do to get around this was edit
/etc/sysconfig/network-scripts/ifcfg-eth0 (or whatever the device is
called) and add the following at the bottom of that file on a line of
its own!

ip link set $DEVICE up
Comment 2 Bernd Bartmann 2004-02-18 10:37:45 EST
I've tried this on RHL9, FC1 and FC2 Test1.

Read comment #5 on big #100527.
Comment 3 Thomas M Steenholdt 2004-02-18 10:48:52 EST
interesting, never looked at it THAT close - the above suggested
solution works okay for me... Although, if there's a bug in the kernel
- it should really be fixed!
Comment 4 Thomas M Steenholdt 2004-02-27 08:35:33 EST
this is a duplicate og bug #100527 - i can't close the bug as a duplicate
Comment 5 Dave Jones 2004-06-14 19:29:09 EDT

*** This bug has been marked as a duplicate of 100527 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:01:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.