Bug 1156023 - [eap6] It's not possible to change a datasource configuration when the EAP6 is in 'needs a reload' state
Summary: [eap6] It's not possible to change a datasource configuration when the EAP6 i...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Configuration, Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: CR01
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Filip Brychta
URL:
Whiteboard:
Keywords: Regression
: 1156414 (view as bug list)
Depends On: 1154988 1156414
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-23 12:18 UTC by Filip Brychta
Modified: 2015-11-02 00:44 UTC (History)
7 users (show)

(edit)
Clone Of: 1154988
(edit)
Last Closed: 2014-12-11 14:02:38 UTC


Attachments (Terms of Use)

Description Filip Brychta 2014-10-23 12:18:20 UTC
+++ This bug was initially created as a clone of Bug #1154988 +++

Description of problem:
Following scenario was working correctly on JON3.3.0.ER04. Probably regression caused by bz 1004977

Version-Release number of selected component (if applicable):
Version :	
4.13.0-SNAPSHOT
Build Number :	
7ceb5f7 

How reproducible:
Always

Steps to Reproduce:
1. clean rhq installation with remote agent monitoring EAP6 standalone
2. navigate to ExampleDS (EAP6 standalone -> datasources -> ExampleDS)
3. invoke operation 'Disable' using default params (Allow service restart == false) - this param was not available in JON3.3.0.ER04
4. try to change a configuration - set 'Max Pool Size' to 30 and click on Save

Actual results:
Configuration update fails with
{JBAS014653: Composite operation failed and was rolled back. Steps that failed:={Operation step-2=JBAS014792: Unknown attribute __OOB}}, rolled-back=true

Expected results:
Configuration update is successful and configuration is applied when the eap6 is reloaded

Comment 1 Filip Brychta 2014-10-23 12:18:32 UTC
Visible in Version :	
3.3.0.ER05
Build Number :	
92b6d6a:2cdb528

as well.

Comment 2 Filip Brychta 2014-10-24 06:41:22 UTC
Automation hit this issue even when the server was not in needs a reload state. I'm not able to reproduce that manually but it seems that the root cause is not 100% accurate.

Comment 3 Radim Hatlapatka 2014-10-24 12:28:41 UTC
*** Bug 1156414 has been marked as a duplicate of this bug. ***

Comment 4 Libor Zoubek 2014-10-27 09:29:19 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/a8e0db310
time:    2014-10-27 10:27:43 +0100
commit:  a8e0db3103d5a0324fc3fe62b9081af0e6fdbe46
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1156023 - [eap6] It's not possible to change a datasource
         configuration when the EAP6 is in 'needs a reload' state

         Removed special __OOB property from config coming from server

Comment 5 Thomas Segismont 2014-10-27 14:18:52 UTC
Cherry-picked over to release/jon3.3.x

  Branch: refs/heads/release/jon3.3.x
  Home:   https://github.com/rhq-project/rhq
  Commit: 57c741afa6a13c11b9d961bb6833030fe5de5036
      https://github.com/rhq-project/rhq/commit/57c741afa6a13c11b9d961bb6833030fe5de5036
  Author: Libor Zoubek <lzoubek@redhat.com>
  Date:   2014-10-27 (Mon, 27 Oct 2014)

  Changed paths:
    M modules/plugins/jboss-as-7/src/main/java/org/rhq/modules/plugins/jbossas7/DatasourceComponent.java

  Log Message:
  -----------
  Bug 1156023 - [eap6] It's not possible to change a datasource configuration
when the EAP6 is in 'needs a reload' state

Removed special __OOB property from config coming from server

(cherry picked from commit a8e0db3103d5a0324fc3fe62b9081af0e6fdbe46)
Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 6 Simeon Pinder 2014-11-03 19:03:41 UTC
Moving to ON_QA as available to test with latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=396547

Comment 7 Filip Brychta 2014-11-04 12:08:29 UTC
Verified on
Version :	
3.3.0.CR01
Build Number :	
08c2f39:6ac97ac


Note You need to log in before you can comment on or make changes to this bug.