Bug 115608 - doesn't recognize netgear 802.11b pcmcia card
doesn't recognize netgear 802.11b pcmcia card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 14:45 EST by Don Hardaway
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 08:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hardaway 2004-02-13 14:45:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a)
Gecko/20031103 Firebird/0.7+

Description of problem:
I can not find a driver to work with my netgear 802.11b pcmcia card
even though it works fine with core 1.  It is automatically identified
in core 1 but test1 core 2 doesn't see it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot up
2.run redhat-config-network
3.try to select a driver
    

Actual Results:  can not get it to work

Expected Results:  it would be automatically recognized.

Additional info:
Comment 1 Don Hardaway 2004-02-13 18:51:10 EST
It would also be nice if core 2 could include the prism54 stuff so my
new netgear wg511 would work.  I have it working with core 1 after
installing some software from prism54.org.
Comment 2 Don Hardaway 2004-02-15 13:20:03 EST
OK, finally got the 802.11b card to work. Had to put the card in the
second pcmcia slot then it kudzu configures the first slot as 3comxxx
and the second slot as orinico_cs which works with my card.  Since my
laptop has builtin ether as well I wonder if it is confusing that port
with the pcmcia.

Now that it works the problem is that upon booting the boot process
hangs until I unplug the 802.11b card then completes booting--then i
plug the card in and it works fine.
Comment 3 Harald Hoyer 2004-02-16 03:53:50 EST
this is more a kudzu issue
Comment 4 Bill Nottingham 2004-02-16 14:00:05 EST
What does kudzu -p -b pcmcia say when it's inserted?
Comment 5 Don Hardaway 2004-02-16 17:08:04 EST
[root@localhost root]# kudzu -p -b pcmcia
-
class: NETWORK
bus: PCMCIA
detached: 0
device: eth2
driver: orinoco_cs
desc: "Intersil PRISM2 11 Mbps Wireless Adapter"
vendorId: 0156
deviceId: 0002
function: 0
slot: 0
[root@localhost root]#


The way I boot now is to leave the card out until the machine is
booted and then insert the card and it works instantly.  If I have the
card in while booting, the boot process hangs at some point and
remains hung until I remove the card and then the boot process
completes.  Then I can reinsert the card and it works fine.

Should I try my netgear wg511 card? Don't know if the new kernel
automatically works with 802.11g or not?
Comment 6 Bill Nottingham 2004-02-16 17:42:50 EST
Hm, this seems to imply that it's getting probed OK.
Comment 7 Warren Lewis 2004-02-21 16:40:06 EST
I have a similar problem with a real orinoco card, the boot process will 
hang if the card is inserted during boot and also sometimes at shutdown.
when the hangs happen the keyboard is unresponsive.  removing the card 
causes an driver error message which I will post when I can grab a
copy of it.  I suspect this is actually a kernel driver problem, not
kudzu or 
system-config-network, can this be moved to kernel component?
Comment 8 Warren Lewis 2004-02-21 17:48:45 EST
Created new bug just in case this is another problem bug 116503, log
attached there.
Comment 9 Harald Hoyer 2004-04-21 09:00:08 EDT
moved to kernel component

Note You need to log in before you can comment on or make changes to this bug.