Bug 1156084 - dnf install @some-environment-id does not work
Summary: dnf install @some-environment-id does not work
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-23 14:18 UTC by Jan Zeleny
Modified: 2015-02-20 08:32 UTC (History)
6 users (show)

Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 08:32:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch to fix the issue (1.84 KB, application/mbox)
2014-10-23 14:18 UTC, Jan Zeleny
no flags Details

Description Jan Zeleny 2014-10-23 14:18:11 UTC
Created attachment 949928 [details]
proposed patch to fix the issue

The problem is simply reproducible:

dnf install @kde-desktop-environment

The installation fails, specifying that the group does not exist. The problem is that when performing the install operation, dnf searches through comps and looks for group with the specified name. However, kde-desktop-environment is not a group, it's an environment. Therefore the installation fails.

I attach a very rough patch that fixes the issue, hope that helps.

Comment 1 Honza Silhan 2014-11-04 12:47:21 UTC
Thanks for help. I made pull request that refactors these commands so the code of "@..." and "group ... ..." uses the same code and works also for "dnf erase @...".

Comment 2 Fedora Update System 2015-02-16 00:03:37 UTC
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21

Comment 3 Fedora Update System 2015-02-17 08:04:29 UTC
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-02-20 08:32:51 UTC
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.