Bug 1156115 - [RFE] don't use dd to copy sparse images in order to save time and bandwith from exportdomain
Summary: [RFE] don't use dd to copy sparse images in order to save time and bandwith f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: 3.6.0
Assignee: Allon Mureinik
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On: 1232161
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-23 15:18 UTC by Sven Kieske
Modified: 2016-02-10 19:44 UTC (History)
16 users (show)

Fixed In Version: vdsm-4.17.0-632.git19a83a2
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 12:58:10 UTC
oVirt Team: Storage
s.kieske: ovirt_requires_release_note+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33355 master MERGED image: use qemu-img convert to copy internal volumes Never

Description Sven Kieske 2014-10-23 15:18:57 UTC
Description of problem:

see this mail:

http://lists.ovirt.org/pipermail/devel/2014-October/009072.html

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
patch at: http://gerrit.ovirt.org/#/c/33355/

Comment 1 Sven Kieske 2015-03-18 16:11:10 UTC
I am not sure the posted patch really deals with the described scenario, so please clarify:

The scenario is: I import a vm from an export domain into a local storage domain.

Would this patch apply in this scenario?

as far as I understood the commit message, the "qemu-img convert" uses
the old image as a backing file and uses copy on write to write the new image.

But afaik this would not work in the above scenario, because the export domain
is just for importing and will be switched off afterwards?

Please correct me if I did not understand your approach correctly, thanks!

Comment 2 Yaniv Lavi 2015-04-02 13:22:55 UTC
How should this be tested?

Comment 3 Allon Mureinik 2015-04-02 15:00:59 UTC
(In reply to Yaniv Dary from comment #2)
> How should this be tested?
Import a VM to a block domain and observe in the VDSM log that it uses qemu-img and not dd.

Comment 4 Sven Kieske 2015-04-02 15:12:49 UTC
This should also work for file backed domains like local storage domains.

If not the posted commit does not belong to this RFE.

Thanks

Comment 5 Michal Skrivanek 2015-04-15 12:16:41 UTC
(In reply to Sven Kieske from comment #4)
> This should also work for file backed domains like local storage domains.

well, the gerrit comment message says it does and provides some numbers...

Comment 6 Michal Skrivanek 2015-04-15 12:16:58 UTC
*commit message

Comment 7 Sven Kieske 2015-04-15 13:16:22 UTC
(In reply to Michal Skrivanek from comment #5)
> (In reply to Sven Kieske from comment #4)
> > This should also work for file backed domains like local storage domains.
> 
> well, the gerrit comment message says it does and provides some numbers...

Thanks for the clarification, I stumbled over this statement:

>  - copying images from block domains we won't copy the entire chunk (1Gb)
> but only the amount of data really in use 

because file domains were not mentioned there, but if you scroll down
I see the tests where also done on file storage.


Thanks for the clarification!

Comment 8 Ori Gofen 2015-08-06 14:17:12 UTC
Verified, 'dd' command is not being used during importation of sparse virtual disks from exportdomain.

Comment 9 Sandro Bonazzola 2015-11-04 12:58:10 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.