Bug 115612 - FC2 doesn't register clicks on laptop touchpad
FC2 doesn't register clicks on laptop touchpad
Status: CLOSED DUPLICATE of bug 112473
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 15:28 EST by Tim Lesher
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lesher 2004-02-13 15:28:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
After a clean install of FC2 test 1, tapping on the laptop's touchpad
does not register a mouse click.  Using the actual mouse buttons works
fine for all six buttons; it's just tapping the touchpad that doesn't
work.

This did work in FC1 release.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into KDE, Gnome, or failsafe
2. Tap mousepad.  
3. Click mouse button.  
    

Actual Results:  No response when tapping touch pad; click registered
when using mouse button.

Expected Results:  click registered using either the touch pad or
mouse button.

Additional info:

The laptop is a VPR Matrix 175B4.  The mouse is configured as a
generic ps/2 mouse with 3-button emulation (as it was in FC1); I've
also tried the Alps and Wheel Mouse configurations.  This also occurs
whether or not gpm is running.
Comment 1 Mike A. Harris 2004-02-13 15:57:16 EST
The mouse driver and other input drivers in XFree86 have not changed
between Fedora Core 1 and current.  I suspect that any difference
in behaviour is caused by kernel changes from 2.4.x to 2.6.x, however
I do not have this hardware and can not test or try to reproduce
this personally.

I'm carbon copying some kernel people who may be able to help
determine if this is a kernel problem or XFree86 problem.
Comment 2 Christopher Johnson 2004-02-14 17:23:59 EST
I have FC1 with both kernel-2.4.22-1.2149.nptl and kernel-2.6.1-1.65
on a Compaq Presario 2100 laptop. 2.4 kernel handles touchpad with
support for tap (acts as click) and scroll section on right side (acts
as scroll wheel).  The 2.6 kernel handles touchpad for mouse movement,
but no response to tap, and scroll area causes mouse vertical movement
instead of scrolling.  This is definitely a kernel problem.

Dmesg excerpt:
Synaptics Touchpad, model: 1
 Firmware: 5.9
 Sensor: 35
 new absolute packet format
 Touchpad has extended capability bits
 -> multifinger detection
 -> palm detection
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
Comment 3 Christopher Barton 2004-02-15 00:21:59 EST
Disabling synaptics support fixed this for me.

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=112473
Comment 4 Mike A. Harris 2004-02-15 00:43:47 EST
Ok, this issue does seem to be a duplicate of bug #112473.  Closing
as dupe...




*** This bug has been marked as a duplicate of 112473 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.