This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 115617 - Wrong layout of Serbian keyboard in xkb
Wrong layout of Serbian keyboard in xkb
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://www.cs.wm.edu/~zvezdan/program...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 17:07 EST by Zvezdan Petkovic
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 08:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for Serbian keyboard layout for XFree86 (5.38 KB, patch)
2004-02-13 17:09 EST, Zvezdan Petkovic
no flags Details | Diff

  None (edit)
Description Zvezdan Petkovic 2004-02-13 17:07:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
I have provided patches for XFree86-4.3.0 on Red Hat Linux 9 at the
web site supplied above.

The layout of the Serbian keyboard in
/usr/X11R6/lib/X11/xkb/symbols/sr
and
/usr/X11R6/lib/X11/xkb/symbols/pc/sr
is wrong for letters Serbian_dje, Serbian_DJE, Cyrillic_zhe,
Cyrillic_ZHE, and characters minus and underscore.  Macedonia_dse and
Macedonia_DSE do not appear in its place.

According to Yugoslav national standard JUS.I.K1.003:

- Serbian_{dje,DJE} should be in place of <],}> US-ASCII key.
- Cyrillic_{zhe,ZHE} should be in place of <\,|> US-ASCII key.
- Macedonia_{dse,DSE} should be in place of <z,Z> US-ASCII key.
- minus and underscore should be in place of </,?> US-ASCII key.

The current layout is provisional and non-standard which causes a lot
of annoyance to a user who is used to standard layout.  Since Serbian
can be written with Latin character set also, it is particularly
annoying when one switches between Latin and Cyrillic script and finds
letters in the different places.

Please compare /usr/X11R6/lib/X11/xkb/symbols/hr,
/usr/X11R6/lib/X11/xkb/symbols/si, and /usr/X11R6/lib/X11/xkb/symbols/yu
and you will see that Zcaron (Cyrillic_ZHE) is at key <BKSL>, that
Dstroke (Serbian_DJE) is at key <AD12>, and <minus,underscore> pair is
at key <AB10>.  These layouts follow the national standard
JUS.I.K1.002 for the Latin script,  while JUS.I.K1.003 is made for the
Cyrillic script, but the layout is absolutely the same.

Please, do correct this error.
The correction respects the national standard.
The correction conforms to the same layout as the Latin script
counterpart in hr, si, or yu layouts.

References:

1. Yugoslav national standard JUS.I.K1.003
2. Yugoslav national standard JUS.I.K1.002
   (both of the above listed in http://www.jus.org.yu/katalog2002/35.pdf
    as Cyrillic and Latin keyboard layout standards, respectively)
3. usr/X11R6/lib/X11/xkb/symbols/hr (see Zcaron, Dstroke and
<minus,underscore>)
4. usr/X11R6/lib/X11/xkb/symbols/si
5. usr/X11R6/lib/X11/xkb/symbols/yu
6. Emacs mule environment Cyrillic-ISO, input method cyrillic-serbian
7. Vim <VIMROOT>/keymap/serbian_utf-8.vim (or serbian_iso-8859-5.vim)
8. My own serbian.kmap for LyX (/usr/share/lyx/kbd/serbian.kmap)


Version-Release number of selected component (if applicable):
XFree86-4.3.0-2.90.55

How reproducible:
Always

Steps to Reproduce:
1. setxkbmap -layout "us,si,sr" -option grp:shift_toggle
2. Press LeftShift + RightShift together to get Serbian Latin keyboard
3. Type ]\/ -- you get &#273;&#382;- (dstroke, zcaron, minus). Fine.
4. Press LeftShift + RightShift together to get Serbian Cyrillic
   keyboard
5. Type ]\/ -- you get [-&#1078; (bracket, minus, Cyrillic_zhe), instead
   of &#1106;&#1078;- (Serbian_dje, Cyrillic_zhe, minus).  Wrong.
    

Actual Results:  [-&#1078; (bracket, minus, Cyrillic_zhe)

Expected Results:  &#1106;&#1078;- (Serbian_dje, Cyrillic_zhe, minus)

Additional info:
Comment 1 Zvezdan Petkovic 2004-02-13 17:09:19 EST
Created attachment 97663 [details]
Patch for Serbian keyboard layout for XFree86
Comment 2 Mike A. Harris 2004-02-13 17:28:07 EST
Please submit a bug report to XFree86.org outlining this issue, and
attaching your patch to the report upstream at:

    http://bugs.xfree86.org

Once you've submitted this request, please update this report
with a URL pointing to the upstream bug report.  We will track
XFree86.org's official resolution to this issue, and will review
the official upstream decision for consideration in our future
erratum.

Thanks in advance.
Comment 3 Zvezdan Petkovic 2004-02-13 17:37:55 EST
Bug reported to XFree86

http://bugs.xfree86.org/show_bug.cgi?id=1176
Comment 4 Mike A. Harris 2004-03-05 02:44:52 EST
Ok thanks, I've carbon copied myself on the upstream bug report
and will track progress and resolution there.  I'll reopen when
there is a status change to report.

Thanks again.
Comment 5 Mike A. Harris 2004-09-01 08:01:41 EDT
Status update:  We no longer ship XFree86, however I see the upstream
XFree86 bug indicates the fix went into CVS.  We now ship X.Org X11
in Fedora Core 2 and current development, which is a separate
project.  I'm not sure if the same fix has went into the X.Org
CVS or not, however I'm assuming the xkb fixes going into XFree86
are being also committed to X.Org as well.

Please test our rawhide xorg-x11 to determine if the fixes are
present in X.Org X11 also.  If it turns out they didn't get included
in X.Org, please file a bug report in X.Org bugzilla to request the
fix get included in the official X11 sources also, and update this
report with your new upstream X.Org bug report URL and we'll track
the issue there as well.

Thanks in advance for testing.


Setting status to "RAWHIDE", pending testing.

Note You need to log in before you can comment on or make changes to this bug.