Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1156259 - Win7-64 guest BSOD(0x000000A0) when doing s4
Summary: Win7-64 guest BSOD(0x000000A0) when doing s4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-24 03:14 UTC by ShupingCui
Modified: 2015-11-24 08:45 UTC (History)
13 users (show)

Fixed In Version: virtio-win-prewhql-0.1-94
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:45:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (35.08 KB, image/jpeg)
2014-10-24 03:16 UTC, ShupingCui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description ShupingCui 2014-10-24 03:14:12 UTC
Description of problem:
Win7-64 guest BSOD(0x000000A0) when doing s4

Version-Release number of selected component (if applicable):
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-2.1.2-4.el7.x86_64

virtio-win-prewhql-0.1-93
QXL driver version: 6.1.0.10018

How reproducible:
100%

Steps to Reproduce:
1. boot win7-64 guest
/bin/qemu-kvm \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga qxl  \
    -global qxl-vga.vram_size=33554432  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20141024-103657-IKE4kzNL,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20141024-103657-IKE4kzNL,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20141024-103657-IKE4kzNL,path=/tmp/seabios-20141024-103657-IKE4kzNL,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20141024-103657-IKE4kzNL,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/root/tests/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win7-64-sp1-virtio.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:6a:6b:6c:6d:6e,id=id2FyTPo,vectors=4,netdev=idlUDlUb,bus=pci.0,addr=05  \
    -netdev tap,id=idlUDlUb \
    -m 4096 \
    -smp 4,cores=2,threads=1,sockets=2  \
    -cpu 'SandyBridge',hv_relaxed,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/root/tests/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -global PIIX4_PM.disable_s4=0 \
    -enable-kvm \
    -monitor stdio

2. do s4 after booting up
3.

Actual results:
guest BSOD(0x000000A0)

Expected results:
guest s4 successfully

Additional info:

Comment 1 ShupingCui 2014-10-24 03:16:12 UTC
Created attachment 950160 [details]
screenshot

I cannot get dump file in guest, guest always on Collecting data for crash dump...

Comment 3 Ronen Hod 2014-10-26 12:26:48 UTC
ShupingCui,

Can you try to isolate a component that triggers the issue. For example virtio-scsi/virtio-net.
Thanks.

Comment 5 ShupingCui 2014-10-27 03:07:13 UTC
(In reply to Ronen Hod from comment #3)
> ShupingCui,
> 
> Can you try to isolate a component that triggers the issue. For example
> virtio-scsi/virtio-net.
> Thanks.

Hi Ronen,

Tried with the following matrix for S4:
|--------------|------------|---------|
| driveformat  | nicmodel   | result  |
|--------------|------------|---------|
| virtio-scsi  | virtio-net | BSOD    |
| virtio-scsi  | e1000      | BSOD    |
| virtio-blk   | virtio-net | PASSED  |
| virtio-blk   | e1000      | PASSED  |
|--------------|------------|---------|

Driver Details:
Red Hat VirtIO SCSI controller
60.71.104.9300

Red Hat VirtIO SCSI pass-through controller
60.71.104.9300

Comment 6 Ronen Hod 2014-10-27 05:45:17 UTC
(In reply to ShupingCui from comment #5)

> 
> Driver Details:
> Red Hat VirtIO SCSI controller
> 60.71.104.9300
> 
> Red Hat VirtIO SCSI pass-through controller
> 60.71.104.9300

Thanks. You certainly nailed it down.

Comment 7 Vadim Rozenfeld 2014-10-27 07:15:25 UTC
(In reply to Ronen Hod from comment #6)
> (In reply to ShupingCui from comment #5)
> 
> > 
> > Driver Details:
> > Red Hat VirtIO SCSI controller
> > 60.71.104.9300
> > 
> > Red Hat VirtIO SCSI pass-through controller
> > 60.71.104.9300
> 
> Thanks. You certainly nailed it down.

Please try downgrading virtio-scsi driver to build 88. At least it should fix crashdump file generation problem. 

Vadim.

Comment 8 ShupingCui 2014-10-29 02:16:02 UTC
(In reply to Vadim Rozenfeld from comment #7)
> (In reply to Ronen Hod from comment #6)
> > (In reply to ShupingCui from comment #5)
> > 
> > > 
> > > Driver Details:
> > > Red Hat VirtIO SCSI controller
> > > 60.71.104.9300
> > > 
> > > Red Hat VirtIO SCSI pass-through controller
> > > 60.71.104.9300
> > 
> > Thanks. You certainly nailed it down.
> 
> Please try downgrading virtio-scsi driver to build 88. At least it should
> fix crashdump file generation problem. 
> 
> Vadim.

Hi Vadim,

Tried downgrading virtio-scsi driver to build 88, do s4 -> PASSED, guest can s4 successfully.

Red Hat VirtIO SCSI pass-through controller
60.71.104.8800

Comment 11 Vadim Rozenfeld 2014-11-24 08:54:34 UTC
Please re-test with drivers from build 94 available at https://brewweb.devel.redhat.com/buildinfo?buildID=399548

Thanks,
Vadim

Comment 12 ShupingCui 2014-11-25 01:45:11 UTC
Tried virtio-scsi driver for build 94, do s4 -> PASSED, guest can s4 successfully.

Red Hat VirtIO SCSI pass-through controller
60.71.104.9400

Comment 13 Vadim Rozenfeld 2014-11-25 06:47:29 UTC
(In reply to ShupingCui from comment #12)
> Tried virtio-scsi driver for build 94, do s4 -> PASSED, guest can s4
> successfully.
> 
> Red Hat VirtIO SCSI pass-through controller
> 60.71.104.9400

Thanks,
Vadim.

Comment 16 lijin 2015-07-17 07:21:05 UTC
change status to verified according to comment#12

Comment 18 errata-xmlrpc 2015-11-24 08:45:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.