Bug 115630 - FC2 - test1 system-config-packages unable to access disk
FC2 - test1 system-config-packages unable to access disk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 19:05 EST by Jared Hogrefe
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.2.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 17:15:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared Hogrefe 2004-02-13 19:05:08 EST
Description of problem:
FC2 -test1  when using the system-config-packages to add packages.
after the system prep the system asks the user to insert the correct
CD "Unable to access disk" error dialog is displayed. 
Error occurs on all of the 4 discs.
If the correct CD is inserted into the cdrom prior to running
system-config-packages the error that is displayed is "Error
installing packages"


Version-Release number of selected component (if applicable):
system-config-packages-1.9.3-2

How reproducible:
always

Steps to Reproduce:
1. use system-config-packages to select packages to add to the system
2. insert the requested cd into the cdrom
3. 
  
Actual results:
error dialogs displayed

Expected results:
install selected rpm packages

Additional info:
Comment 1 Chavdar Ivanov 2004-02-16 08:18:42 EST
*** /usr/share/system-config-packages/method.py,1       2004-02-16
13:19:39.245104576 +0000
--- /usr/share/system-config-packages/method.py 2004-02-16
12:31:10.000000000 +0000
*************** class RedHatCdromInstallMethod(CdromInst
*** 710,716 ****
          self.discidPixmapPath = "/usr/share/pixmaps"
          self.pixmapPath = [ "/usr/share/pixmaps/comps",
"/usr/share/pixmaps" ]
          self.baseDir = "/usr/share/comps/%s" % (getArch(),)
!         self.packagesDir = "RedHat/RPMS"

          if not os.access(self.baseDir + "/.discinfo", os.O_RDONLY):
              GenericError(TYPE_ERROR,
--- 710,716 ----
          self.discidPixmapPath = "/usr/share/pixmaps"
          self.pixmapPath = [ "/usr/share/pixmaps/comps",
"/usr/share/pixmaps" ]
          self.baseDir = "/usr/share/comps/%s" % (getArch(),)
!         self.packagesDir = "Fedora/RPMS"

          if not os.access(self.baseDir + "/.discinfo", os.O_RDONLY):
              GenericError(TYPE_ERROR,
Comment 2 Chavdar Ivanov 2004-02-16 08:19:57 EST
... obvious 
Comment 3 Jeremy Katz 2004-02-16 23:35:35 EST
Obvious, but wrong fix.  It needs to read from the .discinfo file
instead which is on the other branch and just needs merging.  *sigh*
Comment 5 Almacha Raphael Champeimont 2004-02-29 05:44:37 EST
I have an idea for the reason of this bug. 
I am using FC2test1 and system-config-packages-1.9.3-2.1 (last 
update) 
Start a terminal. 
Enter system-config-packages 
Try to install something 
In the terminal you will see something like: 
can't open /mnt/cdrom/RedHat/RPMS/(package name .rpm) 
but if you look in the cdrom you will see that the directory is 
named Fedora and not RedHat. 
So I think that system-config-packages looks in the wrong directory. 
This bug certainly comes from Red Hat and when the directory name 
changed to Fedora they forgot to modifiy system-config-packages. 
This bug both exists in Fedora Core 1 and Fedora Core 2 test1. 
I hope it will be fixed in the next FC2. 
I havce now FC2test1 with an updated system-config-packages 
I looked in .discinfo file where I can read: 
Fedora Core 1.90 
i386 
1 
Fedora/base 
Fedora/RPMS -> This is right but system-config-packages seems not to 
read this line... 
Fedora/pixmaps 
 
Comment 6 Marius Andreiana 2005-08-19 17:15:58 EDT
2002-08-10  Jeremy Katz  
        * src/method.py:
        read information out of .discinfo for all methods

Got no recent bugs about this, should be fixed by the above ChangeLog. If not,
please reopen.

Note You need to log in before you can comment on or make changes to this bug.