Bug 1156343 - auto-install will fail with bond_setup
Summary: auto-install will fail with bond_setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-10-24 09:14 UTC by Yaning Wang
Modified: 2016-02-10 20:07 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Behavior changes in Red Hat Enterprise Linux 7 requires 'boot=' argument to configure bonds, which was causing auto-installation of the Red Hat Enterprise Virtualization Hypervisor 7 to fail when user specified 'boot_setup=' argument, as in Hypervisor 6. These bonding changes are now supported in the Hypervisor and auto-installation of the Hypervisor succeeds as expected with 'bond={bond_name}:{list_of_interfaces}' argument.
Clone Of:
Environment:
Last Closed: 2015-02-11 21:05:07 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
console snapshot (11.62 KB, image/png)
2014-10-24 09:14 UTC, Yaning Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 34515 master MERGED Also recognize bond= at boot Never
oVirt gerrit 35846 ovirt-3.5 MERGED Also recognize bond= at boot Never

Description Yaning Wang 2014-10-24 09:14:48 UTC
Created attachment 950280 [details]
console snapshot

Description of problem:
auto-install will fail with bond_setup

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

auto-install with kargs:

'BOOTIF=bond01 bond_setup=bond01:ens3 storage_init=ata adminpw=xxxxxx firstboot'

Actual results:

install process will fail in very early stage

Expected results:

should successfully installed.

Additional info:

Comment 1 Ryan Barry 2014-10-27 14:18:25 UTC
I'm not able to reproduce a dracut crash. Can you grab a rdsosreport, please?

Comment 2 Ryan Barry 2014-10-27 15:02:01 UTC
Ok, I was able to reproduce a hang. This is a behavior change in EL7, and appears to be the same bug as bz#1149694. There's a problem after the media check with unknown links.

Appending "bond=bond01:ens3" (EL7 dracut) followed by bond_setup=bond01:ens3 works, but this isn't intuitive. We could also recognize bond=... in ovirt-init-functions and recommend that, but I'm not sure.

Fabian, thoughts?

Comment 3 Ryan Barry 2014-10-28 13:36:44 UTC
We'll need a documentation update for this

Comment 4 Ryan Barry 2014-10-28 14:57:01 UTC
Note:

Using bond= to configure bonds will only work on RHEV-H 7. RHEV-H 6 must continue to use bond_setup

Comment 5 Julie 2014-12-02 05:04:08 UTC
Hey Ryan,
   This bug is still on POST. Will this bug make it into downstream for 3.5 GA? It is not clear enough what needs to be documented in the release notes about this bug. If this bug still needs to be called out in the 3.5 GA release notes, please provide doc text in the doc text field. A bit more context than what's written in comment4 would be really helpful as well. 

Cheers,
Julie

Comment 6 Ryan Barry 2014-12-02 14:22:44 UTC
Hey Julie -

I'm not sure if this is going to make it into 3.5 or not, but I'll update the doctext.

Comment 11 Yaning Wang 2014-12-18 09:12:16 UTC
Tested on

RHVH-H 7.0-20141212.0.el7ev
ovirt-node-3.1.0-0.34.el7


Test steps:

auto-install with kargs:

'BOOTIF=bond01 bond=bond01:em1,em2 storage_init= adminpw= firstboot'


Actual Results:

auto-install is success,
bond created without error, can obtain IP correctly

Comment 13 errata-xmlrpc 2015-02-11 21:05:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.