This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 115643 - (IDE VIA) installation doesn't work with SATA drive
(IDE VIA) installation doesn't work with SATA drive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FC2Blocker FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-02-13 23:43 EST by Andrew Schultz
Modified: 2013-07-02 22:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 02:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Schultz 2004-02-13 23:43:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040212

Description of problem:
during bootup to install of Fedora Core2 Test1, the kernel detected my
onboard SATA controller (MSI KT6 Delta) and the drive I have connected
to it.  However, it had trouble and eventually locked up.

it printed the messages:
hde: max request size 1024KiB
hde: lost interrupt
hde: lost interrupt
hde: lost interrupt
hde: 156301488 sectors (80026MB)...

it had more messages, including complaining about DMA, but the CD
media test kicked in before I could write it all down.

Current FC1 kernel (2.4.22-1.2166.nptl) identifies the SATA controller as:
RAID bus controller: PCI device 1106:3149 (VIA Technologies, Inc.)
(rev 128).
the drive is a Seagate Barracude 80GB drive, model ST380013AS

after the media test, the GUI interface came up, but my computer
locked up hard at that point.

I'm guessing there might be a bootup parameter to pass to get SATA
working, but I couldn't find it in the release notes (and the FC1
kernel doesn't need it).
Comment 1 raxet 2004-02-14 15:47:32 EST
In FC2 test 1 during bootup to install the kernel failed to detect my
onboard SATA controller and naturallyt the drive.

My FC1 kernel (2.4.22-1.2166.nptl) identifies the SATA controller as:
02:04.0 RAID bus controller: Promise Technology, Inc. PDC20376 (rev 02)

Forget FC2 test 1 for now... even the work around in building a
2.6.2-1.79 kernel and making a driver disk to boot with fails for
driver sata_promise.ko and scsi_mod.ko.
Comment 2 raxet 2004-02-14 15:49:27 EST
For those interested:

The work around that has proven well in the past but no longer is
found at:
http://www.fys.ku.dk/~esban/promise376.html
Comment 3 Jeff Garzik 2004-03-03 03:27:19 EST
I'm confused...  are you having trouble with the VIA or Promise
controller?
Comment 4 Andrew Schultz 2004-03-03 03:33:04 EST
VIA.  I don't have a Promise controller (raxet does).
Also I tried the development kernel-2.6.3-1.116, and it failed in the
same way.
Comment 5 Jeff Garzik 2004-03-25 21:55:06 EST
Does booting with "noapic" or "nomce" fix things?
Comment 6 Andrew Schultz 2004-03-26 02:18:17 EST
I grabbed kernel 2.6.3-2.1.253.2.1
"noapic", "nomce", both and neither all had the same behavior as I
originally reported.
Comment 7 Dennis Gilmore 2004-04-28 23:15:44 EDT
i have a system with a aopen AK77-600gn  i have a duron 1.6ghz cpu in 
it motherboard with a via SATA controller  i have a WD 80 gb hdd 
attached to it and i got those errors early on i swapped the mobo  
since i had only had it 3 days  the system was unuasable  it would 
randomly drop the sata drive and give a whole bunch of dma and irq 
errors once i replaced the board i upgraded bios to latest available 
and all worked great for awhile  about 3-4 weeks latter the errors 
returned  and the hdd was making intresting sounds  so i returned the 
hdd and got a new one and havent had any problems since i got the HDD 
back  just before easter.  im not 1000% sure if it was kernel related  
but it seemed to be more hardware related. 
 
i never installed FC1 on it as the installer didnt recognise any 
hdd's as being present.  it never detected my SATA controller and 
there is no other HDD's in the system 
Comment 8 Justin M. Forbes 2004-05-03 21:52:31 EDT
This works for me with VIA AMD64 boards, still an issue for others?
Comment 9 Jeremy Katz 2004-05-06 23:26:55 EDT
Is test3 any better?
Comment 10 Andrew Schultz 2004-05-06 23:35:39 EDT
No.  In fact, I tried kernel-2.6.5-1.349 last night.  comment 6 still
holds.
Comment 11 Dennis Gilmore 2004-05-06 23:52:25 EDT
Are you sure its not hardware related?  is there a bios update at 
all?  i had my system up for over a week with no problems running 
2.6.5-1.339 Just rebooted today into 2.6.5-1.350  
 
the relevent part of dmesg for my chipset shows 
 
VIA8237SATA: IDE controller at PCI slot 0000:00:0f.0 
VIA8237SATA: chipset revision 128 
VIA8237SATA: 100% native mode on irq 11 
    ide2: BM-DMA at 0xcc00-0xcc07, BIOS settings: hde:pio, hdf:pio 
    ide3: BM-DMA at 0xcc08-0xcc0f, BIOS settings: hdg:pio, hdh:pio 
hde: ST380013AS, ATA DISK drive 
 
Comment 12 Dennis Gilmore 2004-05-06 23:56:48 EDT
I just realised i put some wrong information in my initial comment  i 
have a seagate SATA drive  not a WD  i got a few WD PATA drives for 
my filesever at the same time  and messed them up. 
Comment 13 Andrew Schultz 2004-05-27 00:37:14 EDT
I upgraded my BIOS which included (among other things):
- Updates VIA SATA ROM version 2.31

but there was no change in the observed behavior (still testing
2.6.5-1.349)
Comment 14 Dennis Gilmore 2004-06-04 08:20:10 EDT
Just wondering how you are going with this?  This week i had my sata 
drive fail.  i ran seagates diagnostic utilities  and it had a whole 
bunch of damage on the surface scan.  I will be taking the drive back 
in the morning  but it will probably take two weeks to get the drive 
back and i am moving OS in three weeks so i wont get to test it much 
until after i have moved.  It seemed to be working great until the 
hdd failed.  i was using 2.6.6-1.377 
Comment 15 Jeff Garzik 2004-06-14 13:44:44 EDT
Part of the problem is that the kernel should be using sata_via not
IDE for the SATA controller.
Comment 16 Dennis Gilmore 2004-06-14 16:53:28 EDT
it is sing sata_via but the driver represents the hdd as an ide one 
not scsi.  if i went to install FC1 or RHEL on the machine i couldnt 
since they dont know how to deal with the via sata chipset  and tell 
me i have no HDD.  
 
with my replacement HDD all seems fine. 
Comment 17 Andrew Schultz 2004-08-13 00:56:40 EDT
I reinstalled FC2 from scratch after accidently nuking my drive.  With
the current kernel (kernel-2.6.7-1.494.2.2), the sata_via is used and
the drive comes up as sda, but it still doesn't work.  It hangs with:

sda:<3>ata2: command 0x25 timeout stat 0x50 host_stat 0x4

I tried noapic and nomce again, but they didn't help.
Comment 18 Dennis Gilmore 2004-08-13 10:37:32 EDT
ok i have had no issues foe awhile now  i replaced my sata data cable 
as it was the only thing that had not been replaced and that seemed 
to finally fix all errors     
Comment 19 Philip Heron 2004-10-04 15:46:32 EDT
Having the same trouble as Andrew Schultz (comment #17). FC2 installer
won't boot because /dev/hde loses an interrupt. Latest FC2 kernel
(2.6.8-1.521) won't boot because /dev/sda times out. The only possible
way to get FC2 to work on this machine is to disable the SATA
controller. I tried one of the FC3 tests (test 1 I believe) and it
crashed with garbled text when the installer loads the sata_via module.

The SATA drive I'm using has FC1 running nicely on it for many months
now, currently using kernel 2.4.22-1.2197.nptl and the sata modules in
the initrd.
Comment 20 Sherry Herrmann 2004-10-18 18:00:59 EDT
I am having a similar problems. FC2 will get all the way to the
installation process then freezes. I get the lost interrupt message
and the 'can't find the dma' at boot up, but the process continues
thru the beginning installation process. It moves incrediably slow but
 still moves on. I have turned ACPI on and off, changed out hardware,
tried linux noprobe, turned off the dma in boot and it happens the
same way everytime. I get to the installation process and the machine
locks up.
I am using the latest version of FC2 downloaded from their site. I
have the latest BIOS upgrade to the MSI KT6 Delta board, and can find
no latest upgrades to the VIA chipset.

What I would like to know is why Mandrake 10.0 Official kernel
2.6.3-7mdk will work and this won't. I would rather use FC2 but if I
can't get it to install I am stuck.
My system is:
AMD 2600xp w/ barton core
MSI KT Delta lsr w/ via sata raid
2xWD Raptor SATA drives 36G each in RAID1 array
256M 333Mhz DDR
Matrox Millenium video

Please forgive if I am posting in the wrong place, I am new to all this!!
Comment 21 Simon Banks 2004-11-04 06:38:56 EST
I've got the exact same problem with FC2, I finaly got my K7
motherboard working with both IDE and SATA drrives with FC1 but
everytime I've tried a FC2 system I get the Lost Interupt/handup
problem. Turning off acpi/pcm makes no difference.

However I did finaly have a problem with my FC1 system when I added a
250 gig SATA drive.  Basicly writes would fail to the SATA drives
until I discovered I could get rid of this problem by disabling the
IDE DMA.

Could this be related?
Comment 22 Simon Banks 2004-11-04 08:37:38 EST
I've got the exact same problem with FC2, I finaly got my K7
motherboard working with both IDE and SATA drrives with FC1 but
everytime I've tried a FC2 system I get the Lost Interupt/handup
problem. Turning off acpi/pcm makes no difference.

However I did finaly have a problem with my FC1 system when I added a
250 gig SATA drive.  Basicly writes would fail to the SATA drives
until I discovered I could get rid of this problem by disabling the
IDE DMA.

Could this be related?
Comment 23 Andrew Schultz 2005-01-17 00:57:12 EST
my hardware is working ok once again with 2.6.10-1.9_FC2
w00t

Note You need to log in before you can comment on or make changes to this bug.