Bug 1156511 - [rfe] use dnf instead of yum
Summary: [rfe] use dnf instead of yum
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-upgrade
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1158551
Blocks: 1156491
TreeView+ depends on / blocked
 
Reported: 2014-10-24 15:32 UTC by Rahul Sundaram
Modified: 2015-10-11 11:39 UTC (History)
3 users (show)

Fixed In Version: fedora-upgrade-23.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-11 11:39:09 UTC
Type: Bug


Attachments (Terms of Use)
yum to dnf migration (7.71 KB, patch)
2015-03-19 15:11 UTC, Michael Mráka
no flags Details | Diff

Description Rahul Sundaram 2014-10-24 15:32:44 UTC
Description of problem:

Fedora 22 is planning to switch over to dnf from yum as per

https://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF

Please switch from  yum/yum-utils to dnf/dnf-plugins-core. Thanks!

Comment 1 Miroslav Suchý 2014-10-29 15:55:15 UTC
fedora-upgrade will be migrated sometime around F23 Alpha. Because only some time around F23 Alpha I will be creating package for F22 to create upgrade to F23.

However I am aware of this change and I'm investigating the deps and if needed requesting RFE in DNF so DNF is ready.

Comment 2 Michael Mráka 2015-03-19 15:11:18 UTC
Created attachment 1003868 [details]
yum to dnf migration

Hello, here is patch which migrates your project from yum to dnf.
The patch has not undergone any formal tests.
Please run your project tests to minimize possible regressions.

Thanks.

Comment 3 Miroslav Suchý 2015-10-11 11:39:09 UTC
Patch applied (after rebase) as dd38ec1.
Current code already use DNF.


Note You need to log in before you can comment on or make changes to this bug.