Bug 115656 - Misdetection of PS/2 hangs entire system
Summary: Misdetection of PS/2 hangs entire system
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-14 14:22 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 17:11:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-02-14 14:22:50 UTC
Description of problem:

ASUS dual athlon SMP box. No PS/2 mouse. The kernel detects a PS/2
mouse and attempts to enable it. This jams IRQ 12 which the box then
disables. Unfortunately IRQ12 is actually assigned to the scsi
controller so the machine then drops dead.

Version-Release number of selected component (if applicable):

FC2 test1

How reproducible:
100%


Steps to Reproduce:
1. Install on ASUS A7M 266D
2. Reboot
3. Observe
  
Actual results:

Hang (both SMP and non SMP)

Expected results:

Working system as with all previous releases.

Additional info:
The boot kernel works for some reason, although it too sees phantom
PS/2 mice. The phantom ports seem to be a 2.6 kernel bug as 2.4 gets
the detection right.

acpi=off does not help (it simply produces irq routing table errors
then hangs)
apm=off acpi=off pci=noacpi also doesnt help

Comment 1 Alan Cox 2004-04-21 17:11:44 UTC
The ps/2 specific issue seems to be ok now



Note You need to log in before you can comment on or make changes to this bug.