This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 115665 - (ACPI) Dual athlon needs acpi=off
(ACPI) Dual athlon needs acpi=off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-02-14 10:31 EST by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 18:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-02-14 10:31:52 EST
On an AMD dual athlon you need acpi=off pci=usepirqmask together.
Surely acpi=off should stop trying to use acpi routing data ?? 

[Box works reliably in 2.4]

It then later dies with a spew of oops data from a network operation
of some kind.
Comment 1 Alan Cox 2004-02-14 12:46:40 EST
Ok its crashing reliably on the ifconfig ifup of the network card
(netgear). 

dev->change_flags (hence I guess ifup)
dev->open
alloc_skb
cache_init_obs
then an IRQ coming in
and can't recover the top of the trace

So it looks like a network driver with incorrect irq protection
Comment 2 Alan Cox 2004-02-15 12:22:02 EST
Network oops turns out to be a side effect of the broke acard scsi
module it seems (that or its just chance that acard scsi puts the
corruption somewhere that matters).

Other stuff still the same
Comment 3 Dave Jones 2004-06-14 19:32:45 EDT
how's things looking with the current kernel on this box ?

do we need to fiddle stuff based on dmi strings ?

Is it worth adding the acpi folks
(acpi-bugzilla@lists.sourceforge.net) to the cc: of this bug ? or is
the DSDT too broken for them to work around?
Comment 4 Alan Cox 2004-06-14 19:40:31 EDT
Will investigate further
Comment 5 Alan Cox 2004-10-01 18:30:07 EDT
Works properly with FC3test2 so I guess the bug is fixed now

Note You need to log in before you can comment on or make changes to this bug.