Bug 115666 - Radeon 9600 hangs after agp access
Radeon 9600 hangs after agp access
Status: CLOSED DUPLICATE of bug 78616
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 10:44 EST by Dirk
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk 2004-02-14 10:44:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
I have testet this with kernel 2.4.24 and it works
I have testet it with build in Kernel 2.4.21-9.EL and it fails

In my opinion the Problem is that my nvidia nforce 2 board is not 
correctly recognized by RHEL 3 Kernel.

The Problem appears if I run the fgl_glxgears which comes with the 
ati driver (and access the agp i think), then the Screen freezes and 
the system hang.

So if that is the Problem please include updated nforce drivers in 
RHEL Kernel 

Version-Release number of selected component (if applicable):
newest fglrx driver from ATI

How reproducible:
Always

Steps to Reproduce:
1. Download the Ati Linux driver from www.ati.com
2. Install the Ati Linux driver 
3. Run the ATI XFree Config Script and disable internal agp support
4. Restart X 
    

Actual Results:  X hangs or doesn't start at all

Expected Results:  X should start correctly

Additional info:
Comment 1 Mike A. Harris 2004-02-14 13:04:14 EST
Red Hat does not support 3rd party video drivers or kernel
modules.  Please contact ATI directly for technical support
assistance for problems encountered with their drivers.



*** This bug has been marked as a duplicate of 78616 ***
Comment 2 Dirk 2004-02-15 07:29:08 EST
No the Problem exist because in Kernel 2.4.21 an corrupt agpgart 
nvidia Driver included, and this is fixed i think in kernel 2.4.22 
Vanilla, and i am not shure, but i think red hat hasn't fix it in 
they'r enterprise kernel.
Comment 3 Mike A. Harris 2004-02-15 15:59:58 EST
In any case, agpgart is not part of XFree86, so XFree86 is totally
unrelated to the problem reported in this report.   Reassigning
to the kernel component for kernel engineer evaluation.
Comment 4 Arjan van de Ven 2004-02-15 16:07:16 EST
the ati driver comes with their own AGP driver that ignores the kernel
one.


*** This bug has been marked as a duplicate of 78616 ***
Comment 5 Dirk 2004-02-16 08:36:52 EST
That is right but you can turn off internal agpgart driver so I do, 
because the internal agpgart doesn't work for my nforce Board, this 
is a known bug in ATI Driver and NOT the  reason for this report, but 
if i use kernel 2.4.24 vanilla instead of kernel 2.4.21EL it works. 
The only problem i have if I use kernel 2.4.24 vanilla is that there 
is no ntpl included, and it seems that some (gnome) applications  
essentially need ntpl. So I think that agpgart Code in RHEL 2.4.21 is 
not the recent on, but I didnt know for shure.
Comment 6 Red Hat Bugzilla 2006-02-21 14:01:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.