Bug 115668 - Kernel panic on Compaq Proliant 2500
Kernel panic on Compaq Proliant 2500
Status: CLOSED DUPLICATE of bug 36940
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2004-02-14 11:18 EST by Max E
Modified: 2007-04-18 13:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Max E 2004-02-14 11:18:25 EST
Description of problem:
When trying to install RH9 from CD, I am constantly getting a kernel 
panic from operating system when trying to install

Version-Release number of selected component (if applicable):
Redhat 9.0 (Shrike)

How reproducible:
Insert installation CD1 CDROM into machine, where it starts to boot.
We then get to the point where the system is looking for a boot 
partition.  However, we get a kernel panic on VFS.  Have tried with 
all manner of kernel arguments, but still no joy. 

Steps to Reproduce:
1. Switch on server
2. Insert installation CD1 (RH9) CDROM into machine, so it boots off 
3. wait until the kernel panic occurs
Actual results:

VFS: cannot open root device "" or 48:01

Expected results:

Should allow me to install operating system

Additional info:
Comment 1 Max E 2004-02-14 11:30:14 EST
OK additional information:

The machine is a compaq proliant 2500 (a bit old, but still 
functional) with 4 internal SCSI drives (4.5GB a piece), 448M of RAM 
(actual mem is 458752), dual processor, with a Compaq Smart-2/P Array 
controller (2.14 rev B) - latest, and an array of 6 discs, making up 
32GB in total.

I have tried booting with the following kernel arguments, but to no 

linux nousb nodma skipddc apm=off mem=448M noapic noht nousbstorage

I have also tried putting in a boot argument of root=/dev/ida/c0d0p1 
as well as root=/dev/ida/c1d0p1 (to try and access SMART array); root 
= dev/sda/sda0 to access internal drives.

The machine is very capable, but probably just needs the correct boot 
arguments.  I know that RH 6.2 boots up without problems, but 7.0 
onwards fails with same errors.  Thought the problem might be to do 
with cpqarray.o, but thought that this was included in the kernel for 

Full error message as follows:

VFS: Cannot open root device "ida/c0d0p1" or 48:01.  Please append a 
correct "root=" option.

Kernel panic: VFS: Unable to mount root fs on 48:01

I get similar messages when inserting boot=/dev/sda/sda0 into the 
boot argument, but get error message:

VFS: Cannot open root device "sda/sda0" or 8:01
Comment 2 Peter E. Popovich 2004-02-17 17:39:15 EST
I just worked through this myself. I'll bet a dollar this is a
duplicate of bug 36940.

instead of "mem=448M", try "mem=exactmap mem=640K@0 mem=447M@1M"

and in LILO, check to make sure you've got this:
append=" mem=exactmap mem=640K@0 mem=447M@1M"
(don't ask me how you do it in GRUB.)

ref: http://www.cpqlinux.com/memory.html#METHOD3
Comment 3 Max E 2004-02-17 17:45:13 EST
Thanks - that worked a treat.  Blimey, nothing like a challenge with 
these Compaq boxes.  I'm now order more HD space, so I'll well 
chuffed.  Thanks for that.

*** This bug has been marked as a duplicate of 36940 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.