Bug 1156685 - qt5-qttools: libQt5Designer should be in a subpackage
Summary: qt5-qttools: libQt5Designer should be in a subpackage
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qttools
Version: 21
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2014-10-25 04:42 UTC by Kevin Kofler
Modified: 2014-10-30 14:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-30 14:43:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Kofler 2014-10-25 04:42:37 UTC
Description of problem:
Several packages, e.g. phonon-qt5, ship Qt Designer plugins. Those are in the main package because some bindings (notably PyQt) also use them at runtime. Unfortunately, this currently makes them drag in the whole qt5-qttools package. The library needs to be packaged separately.

Version-Release number of selected component (if applicable):
qt5-qttools-5.3.2-1.fc21

How reproducible:
Always.

Steps to Reproduce:
1. yum install phonon-qt5

Actual results:
All of qt5-qttools dragged in (including dependencies such as clucene09-core).

Expected results:
Only the library gets dragged in.

Comment 1 Kevin Kofler 2014-10-25 14:06:00 UTC
Looking at what the main package contains, I suggest 2 additional subpackages:

keep in qt5-qttools:
%{_bindir}/qdbus-qt5
%{_bindir}/qtpaths
%{_qt5_bindir}/qdbus*
%{_qt5_bindir}/qtpaths

qt5-qtdesigner-libs or qt5-designer-libs:
%{_qt5_libdir}/libQt5Designer.so.5*
%{_qt5_libdir}/libQt5DesignerComponents.so.5*

qt5-qthelp:
%{_qt5_libdir}/libQt5CLucene.so.5*
%{_qt5_libdir}/libQt5Help.so.5*

move to -devel (belongs to Linguist and should not be needed at runtime):
%{_qt5_datadir}/phrasebooks/

Comment 2 Kevin Kofler 2014-10-25 14:10:36 UTC
PS: Or if something does need the phrasebooks at runtime, put them into a third new subpackage (like qt5-linguist-phrasebooks).

Comment 3 Rex Dieter 2014-10-25 21:10:57 UTC
I agree with comment #1 , let's go with that plan.

Comment 4 Rex Dieter 2014-10-25 21:31:51 UTC
working on it...

Comment 5 Rex Dieter 2014-10-25 21:42:13 UTC
Based on this, looks like we may want more than 2 subpkgs.  either 3 (one for each of the first 2, another for the rest), or 4 (one for each library).

(size ~5.1Mb)
$ repoquery --whatrequires 'libQt5Designer.so.5()(64bit)'
kf5-kdelibs4support-0:5.3.0-1.fc20.x86_64
phonon-qt5-0:4.7.0-8.fc20.x86_64
qt5-designer-plugin-webkit-0:5.3.2-1.fc20.x86_64
qt5-qtquick1-0:5.3.2-1.fc20.x86_64
qt5-qttools-devel-0:5.3.2-1.fc20.x86_64

(size ~600Kb)
$ repoquery --whatrequires 'libQt5Help.so.5()(64bit)'
qt5-assistant-0:5.3.2-1.fc20.x86_64
qt5-qttools-devel-0:5.3.2-1.fc20.x86_64
qt5-qttools-examples-0:5.3.2-1.fc20.x86_64

(size ~2.6Mb)
$ repoquery --whatrequires 'libQt5DesignerComponents.so.5()(64bit)'
qt5-qttools-devel-0:5.3.2-1.fc20.x86_64

(size ~150Kb)
$ repoquery --whatrequires 'libQt5CLucene.so.5()(64bit)'
qt5-qttools-devel-0:5.3.2-1.fc20.x86_64

Comment 6 Rex Dieter 2014-10-30 14:43:25 UTC
%changelog
* Sat Oct 25 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-0.3.beta
- libQt5Designer should be in a subpackage (#1156685)
- -doc: disable(boostrap for new clucene), drop dep on main pkg


Note You need to log in before you can comment on or make changes to this bug.