Bug 1156687 - kf5-frameworkintegration: libKF5Style should be in a subpackage
Summary: kf5-frameworkintegration: libKF5Style should be in a subpackage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-frameworkintegration
Version: 21
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2014-10-25 04:46 UTC by Kevin Kofler
Modified: 2015-11-02 01:38 UTC (History)
7 users (show)

Fixed In Version: kf5-frameworkintegration-5.3.0-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-01 17:07:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Kofler 2014-10-25 04:46:47 UTC
Description of problem:
KDE-based Qt 5 widget styles, such as Oxygen for Qt 5, depend on libKF5Style. It should be possible to use them in KDE 4 or non-KDE environments without dragging in the whole kf5-frameworkintegration with its many dependencies. The library needs to be packaged separately.

Version-Release number of selected component (if applicable):
kf5-frameworkintegration-5.3.0-1.fc21

How reproducible:
Always.

Steps to Reproduce:
1. enable https://copr.fedoraproject.org/coprs/kkofler/kannolo/
2. yum install plasma-oxygen

Actual results:
All of kf5-frameworkintegration dragged in (including many dependencies).

Expected results:
Only the library (with its dependencies) gets dragged in.

Comment 1 Fedora Update System 2014-10-26 19:27:17 UTC
kf5-frameworkintegration-5.3.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kf5-frameworkintegration-5.3.0-3.fc20

Comment 2 Fedora Update System 2014-10-26 19:28:27 UTC
kf5-frameworkintegration-5.3.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kf5-frameworkintegration-5.3.0-3.fc21

Comment 3 Fedora Update System 2014-10-27 08:19:07 UTC
Package kf5-frameworkintegration-5.3.0-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kf5-frameworkintegration-5.3.0-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13669/kf5-frameworkintegration-5.3.0-3.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-11-01 17:07:54 UTC
kf5-frameworkintegration-5.3.0-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.