Bug 115678 - Firstboot crashes on reboot
Summary: Firstboot crashes on reboot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-14 19:20 UTC by Jean Francois Martinez
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-16 21:37:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The python stack when firstboot crashes (892 bytes, text/plain)
2004-02-14 19:22 UTC, Jean Francois Martinez
no flags Details

Description Jean Francois Martinez 2004-02-14 19:20:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
firstboot crashes either when I boot first time and when I run it from
an xterm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install (selcting french as the default language)
2.  Reboot
3.
    

Additional info:

Comment 1 Jean Francois Martinez 2004-02-14 19:22:36 UTC
Created attachment 97672 [details]
The python stack when firstboot crashes

Comment 2 Jean Francois Martinez 2004-02-15 07:59:08 UTC
I used the configurator to change the language to US english, exited
the session and restarted first boot from an xterm.  It worked.  So it
is definitely a language problam.

Comment 3 Bill Nottingham 2004-02-16 05:56:52 UTC
Looks like a bad translation?

Comment 4 Dimitri Papadopoulos 2004-02-16 18:24:07 UTC
Yes, a bad translation. The funny thing is that firstboot fails on a
different line here, 1670 instead of 2560, although we're probably
running the same version (I'm running firstboot-1.3.3-3):

(firstboot.py:1670): Gtk-WARNING **: Invalid input string

(firstboot.py:1670): Gtk-WARNING **: Invalid input string
Traceback (most recent call last):
[...]
  File "/usr/lib/python2.3/site-packages/rhpl/translate.py", line 202,
in gettext
    return string.encode("UTF-8")
UncidoeDecodeError: 'utf8' codec can't decode bytes in position 12-14:
invalid data


Comment 5 Brent Fox 2004-02-16 21:37:04 UTC
fr.po was not UTF-8 encoded for some reason.  I converted it and
committed it to cvs.  Should be fixed in firstboot-1.3.4-1.  Thanks
for your report.


Note You need to log in before you can comment on or make changes to this bug.