Bug 115680 - insmod error inserting toshiba_acpi.ko
Summary: insmod error inserting toshiba_acpi.ko
Status: CLOSED DUPLICATE of bug 107199
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-14 19:48 UTC by Jason
Modified: 2014-03-17 02:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason 2004-02-14 19:48:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
I have a Tyan Tiger 1832DL motherboard.  It is a P3 850Mhz system.  I
modified my grub.conf to set acpi=force so ACPI would work.  When I do
this I get an error during startup:  insmod error inserting
/lib/modules/2.6.1-1.65/kernel/drivers/acpi/toshbia_acpi.ko :-1 no
such device.  I don't have anything toshiba in my system.  This error
also happens with redhat 9 and FC1 with ACPI=force.  I think the error
is harmless but it is annoying.

This error also occurs on several intel motherboards when acpi=on.

ACPI works on all of the systems.  The systems power off after a
shutdown and the power button does a shutdown.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  set acpi=force
2.  on an acpi motherboard
3.  
    

Actual Results:  the error is displayed during boot

Expected Results:  no error

Additional info:

Comment 1 Dave Habben 2004-02-15 03:08:39 UTC
This is caused by these lines in the /etc/rc.d/rc.sysinit

# Initialiaze ACPI bits
if [ -d /proc/acpi ]; then
   for module in /lib/modules/$unamer/kernel/drivers/acpi/* ; do
      insmod $module
   done
fi

Perhaps this could be turned into a RFE for the toshiba_acpi to not
complain quite so loudly. Either that or to not load the asus_acpi or
toshiba_acpi unless a machine supporting it is detected.

Comment 2 Bernd Bartmann 2004-02-15 15:47:36 UTC
Same error message error with an ECS K7S5A mainboard and an Athlon
2200 XP+ cpu.

Comment 3 Bill Nottingham 2004-02-16 04:04:24 UTC

*** This bug has been marked as a duplicate of 107199 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.