Bug 115690 - anaconda crashes at start of package install.
anaconda crashes at start of package install.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
other Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-14 18:05 EST by Jim McDonald
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 19:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim McDonald 2004-02-14 18:05:04 EST
Description of problem:  Anaconda dies after two disks are partioned
(probably) and before first (probably) package is loaded.

Version-Release number of selected component (if applicable): version
3.  RedHat Enterprise Linux for the AMD64 architecture.

How reproducible:  Exception error everytime on the only AMD64 bit
machine I have.  Does not seem to matter how disks are partitiond or
how many packages are chosen to install.


Steps to Reproduce:
1.  Boot from CD ROM
2.  Proceed through graphical or text version of anaconda.
3.  In graphical version I observe the partitions being formated. 
Either after or during the formating of last partition (I suspect
after from both the screen behavior and the traceback calls) an
exception notice pops up.
  
Actual results: Cannot get through installation process


Expected results: Successful installation of Linux


Additional info:
Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 943, in handleRenderCallback
	self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py, line 156, in
renderCallback
	self/intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py, line 768, in nextClicked
	self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
	self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
	rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 613, in doPreInstall
	method.mergeFullHeaders(id.grpset.hdrlist)
File "/usr/lib/anaconda/image.py",line 58, in mergeFullHeaders
	hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
File "/usr/lib/anaconda/hdrlist.py", line 329, in mergeFullHeaders
	rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
error: match tag mismatch

This system is brand new.  There are two 38G drives.  All drives but
swap are formatted to ext3.  Does not seem to matter if the default
configuration is selected or if a customized partitioning is used.
Comment 1 Jim McDonald 2004-02-16 19:34:48 EST
I ran the checkmedia option and found that the only three times the cd
check was run, it failed on the first run and then passed on the
second run without doing anything to the cd and/or cdrom other than
pushing the cdrom door closed and re-running checkmedia.  In two out
of two times I was successful in running anaconda and installing
packages after exiting the check media utility.  There were no
apparent read problems with the cd.  Since I now have the machine
configured as desired I do not wish to experiment further.  

From my point of view the priority of this problem is now low.

Thanks
Comment 2 Jeremy Katz 2004-02-17 19:46:11 EST
This sounds like an incompatibility between your media and your drive.+
Comment 3 Jim McDonald 2004-02-18 10:06:21 EST
Maybe, but everything else seems to work including booting off of the
cdrom.
Comment 4 Zak Brown 2005-01-26 17:56:19 EST
I'm having the same issue with ES3, update 3.  My machine is a
Supermicro with an Intel CPU.
Comment 5 Rob 2005-05-26 14:01:44 EDT
(In reply to comment #4)
> I'm having the same issue with ES3, update 3.  My machine is a
> Supermicro with an Intel CPU.

roger. same problem.
Comment 6 Eric Laflamme 2005-10-13 20:47:58 EDT
Same problem with Redhat ew 3 Update 5, on a AMD 64 Dual core system, in 
64bits.

anaconda crash on different package, over the time, and some time (1 of 3) it 
work fine and I`m able to install all Redhat.  

need to reopen the bug!!!!!!!!

Note You need to log in before you can comment on or make changes to this bug.