Bug 115705 - Up2date stops responding while checking dependencies.
Up2date stops responding while checking dependencies.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks: FC2Blocker FC3Target 124619 FC4Target
  Show dependency treegraph
 
Reported: 2004-02-14 22:53 EST by Les Hehe
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 4.4.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 09:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date and/or python chucking its cookies (3.05 KB, text/plain)
2004-02-15 06:46 EST, Rick Richardson
no flags Details

  None (edit)
Description Les Hehe 2004-02-14 22:53:41 EST
Description of problem:
Stops responding

Version-Release number of selected component (if applicable):
RC1

How reproducible:
4 repeat failures

Steps to Reproduce:
1. Run up2date
2. Get list of updates
3. Check for dependencies
  
Actual results:
Shows only 131k files to d/l. 30 minutes later, still stuck on
checking dependencies.

Expected results:
Completion of updates.

Additional info:
I have broadband, so d/l should complete in less than 1 minute.
Comment 1 Rick Richardson 2004-02-15 06:41:25 EST
Same problem here.  First its shows that only 192kb of files will be
downloaded.  This, even though there are dozens of updates, from
kernel thru gcc, since FC2T1 was released a few days ago (perhaps very
prematurely, even for testers).  When it gets to computing the package
dependencies, it just hangs.

When run from the command line, I get a completely useless traceback
error from (ugh!) python.  I've attached it as a file.

There are so many things new bugs introduced with FC2T1 (vs. say RH8)
that I don't even want to start filing bug reports against it until I
am completely up2date.  But I am quickly burning out.

Comment 2 Rick Richardson 2004-02-15 06:46:56 EST
Created attachment 97685 [details]
up2date and/or python chucking its cookies

Python sucks.
Comment 3 Les Hehe 2004-02-17 03:18:36 EST
Maybe I better ask... Just how long should it take to test the
packages and resolve inter-dependencies ?? 

After restarting the Up2date process a few times, it appears to
downloading something from the net, but I don't get any progress
indicated on the progress bar.

I've let it run for about 20 minutes this time. My hub indicates
traffic to the port going to my test machine, but still seems to be
stalled. 
Comment 4 Warren Togami 2004-04-17 06:37:39 EDT
Is it still bad with test2, or latest rawhide?
Comment 5 Les Hehe 2004-04-17 19:26:18 EDT
Have not installed test2 yet. I have d/l it, but haven't found the
time to do a fresh install on the test machine. I'll try this weekend
and let you know the progress.
Comment 6 Nils Philippsen 2004-04-21 09:53:11 EDT
Rick, Les -- did you test with current Rawhide?
Comment 7 Les Hehe 2004-04-22 01:49:58 EDT
Installed FC2-T2 this weekend, and had issues with up2date. Was not
able to launch from taskbar, but would launch from terminal session.
There were about 14 packages that failed key signatures. 

I've been working wierd hours for the last 3 days and haven't had a
chance to continue testing, but will try a re-install to see if I get
different results. It could be the server was too busy, and I didn't
get a good connection to the server. Up2date did take almost 2 hours
to complete the d/l process before it started the actual update.
Comment 8 Jef Spaleta 2004-05-05 20:26:49 EDT
fyi, in installed a fresh test3 install may 3rd and initial up2date
usage to install updates seemed to work fine. Sorry didn't time how
long it takes.

Did a second round of updates this evening, 34 updates, on a k6-2 400
MHz 192 Megs ram. Its taking a few minutes to do the dep resolution on
this system, but certaintly not 10 minutes. I'm watching the up2date
process in top, and its keeping the cpu active so whatever time its
taking seem legit. 


-jef
Comment 9 Les Hehe 2004-05-09 05:15:44 EDT
I shelved the Athlon for further testing and replaced it with a
Celeron 633 and 128MB ram. The install was standard, and without
errors. Up2date did run from the taskbar, and the dependencies process
completed in about an hour. Moving to the "Installing packages"
started, but after an hour of thrashing the hard drive with no
progress, I had to pull the plug on it.
Comment 10 glen bittner 2004-11-13 22:02:42 EST
Tried up2date selecting all packages with same stopped responding. 
Tried again with only 2 packages selected,  ok.  Will try again to
select all packages once I get below 16 packages available.
Comment 11 Adrian Likins 2005-05-19 16:14:17 EDT
This behaviour has been mitigated with the 4.4.x releases. 
Comment 12 John Thacker 2006-10-29 09:49:10 EST
Closing since behavior has been mitigated, and up2date has been replaced by
pirut/pup on the still fully supported FC releases, FC5 and FC6.

Note You need to log in before you can comment on or make changes to this bug.