Bug 1157229 - [RestApi] Adding Vm to an un-initialized dc, creates an unusable, unremovable VM entitiy
Summary: [RestApi] Adding Vm to an un-initialized dc, creates an unusable, unremovable...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: sefi litmanovich
URL:
Whiteboard:
: 1225931 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-26 11:21 UTC by Ori Gofen
Modified: 2016-05-26 01:51 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 01:10:12 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 35454 0 master MERGED core: Fix CDA for AddVmCommand Never

Comment 1 Omer Frenkel 2014-10-26 17:53:48 UTC
how this is urgent?

Comment 2 Ori Gofen 2014-10-26 20:15:10 UTC
I mistakenly revealed my server's ip, set description to private due to that

Comment 3 sefi litmanovich 2015-06-02 08:06:07 UTC
Verified with ovirt-engine-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch.

If I understand correctly from the patch, the addVmCommand canDoAction function will now deny adding a vm to an uninitialized dc as described in this bz with the error 'ACTION_TYPE_FAILED_IMAGE_REPOSITORY_NOT_FOUND'.

This is the behaviour I'm getting when:
1. adding new dc.
2. adding new cluster.
3. dc is uninitialized.
4. add vm with to new cluster.

<fault>
<reason>Operation Failed</reason>
<detail>
[Cannot add VM: Storage Domain cannot be accessed. -Please check that at least one Host is operational and Data Center state is up.]
</detail>
</fault>

Comment 4 Omer Frenkel 2015-06-02 08:23:28 UTC
*** Bug 1225931 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.