Bug 1157294 - Bulk Actions - Errata - Message states more errata than exist
Summary: Bulk Actions - Errata - Message states more errata than exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Brad Buckingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-27 01:37 UTC by Paul Armstrong
Modified: 2019-09-25 20:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:11:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Paul Armstrong 2014-10-27 01:37:15 UTC
Description of problem:

For Bulk Action for Errata - Scrolling to the end of the list displays (e.g.) 160 of 141 Errata 
-should only display 141 of 141 Errata

For Bulk Action for Errata - Selecting all using the top checkbox displays (e.g.) 160 Selected 
-should only display 141 Selected or whatever the total number of errata are

For Bulk Action for Errata - Selecting Install Select displays  "Are you sure you want to apply the 160 selected errata to the content hosts chosen?"
Should state "Are you sure you want to apply the 141 selected errata to the content hosts chosen?"

Version-Release number of selected component (if applicable):6.0.4


How reproducible: Always


Steps to Reproduce:
1. Select Bulk Actions for host with errata
2. Scroll to the bottom of the list of errata - items listed will a multiple of the fetch request even if there are fewer items returned
3. Selecting all the errata shows the number selected to be the multiple of the fetch request and not the number of errata that apply
4. Selecting install selected displays a message indicating the multiple of the fetch request and not the number of errata that apply


Actual results:
See above

Expected results:
Numbers are accurately displayed and action messages accurately reflect selected actions.

Additional info:

Comment 1 RHEL Product and Program Management 2014-10-27 01:52:53 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2015-09-10 13:33:10 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.

RPMs installed:
  ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
  foreman-1.7.2.34-1.el7sat.noarch

Moving to ON_QA for verification.

Comment 4 Paul Armstrong 2015-09-10 17:18:33 UTC
I no longer see this in 6.1.1
Thanks!

Comment 5 Brad Buckingham 2016-03-24 20:09:24 UTC
Tested the scenario based on the description above and am not able to reproduce it with Satellite 6.2 snap 5.  This is consistent to what we saw on 6.1.1 above; therefore, moving to VERIFIED.

Comment 8 errata-xmlrpc 2016-07-27 09:11:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.