Bug 1157324 - adwaita-icon-theme: Please (re)introduce adwaita-cursor-theme subpackage
Summary: adwaita-icon-theme: Please (re)introduce adwaita-cursor-theme subpackage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: adwaita-icon-theme
Version: 21
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2014-10-27 03:13 UTC by Kevin Kofler
Modified: 2014-11-10 06:29 UTC (History)
2 users (show)

Fixed In Version: adwaita-icon-theme-3.14.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 06:29:37 UTC
Type: Bug


Attachments (Terms of Use)
proposed adwaita-icon-theme.spec patch (3.01 KB, patch)
2014-10-27 12:16 UTC, Rex Dieter
no flags Details | Diff
proposed gnome-themes-standard.spec patch (917 bytes, patch)
2014-10-27 12:17 UTC, Rex Dieter
no flags Details | Diff

Description Kevin Kofler 2014-10-27 03:13:10 UTC
Description of problem:
Adwaita is the default cursor theme in Fedora, hardcoded in the libXcursor package (by making /usr/share/icons/default inherit it). (For that reason, it is also a dependency of kde-settings.) Unfortunately, that theme now cannot be installed without a >11 MiB icon theme.

Version-Release number of selected component (if applicable):
adwaita-icon-theme-3.14.0-1.fc21

How reproducible:
Always

Steps to Reproduce:
1. Try to install adwaita-cursor-theme.

Actual results:
adwaita-cursor-theme is only a Provides of the huge adwaita-icon-theme package.

Expected results:
adwaita-cursor-theme is a small subpackage of adwaita-icon-theme containing only /usr/share/icons/Adwaita/cursors and not the icons.

Additional info:
I hit this on the KDE-only Fedora Remix "Kannolo" I'm working on.

Comment 1 Rex Dieter 2014-10-27 12:16:51 UTC
Created attachment 950971 [details]
proposed adwaita-icon-theme.spec patch

Comment 2 Rex Dieter 2014-10-27 12:17:27 UTC
Created attachment 950972 [details]
proposed gnome-themes-standard.spec patch

Comment 3 Kalev Lember 2014-10-28 12:04:37 UTC
I pushed a slight variation of the patch, does this work for you guys?

http://pkgs.fedoraproject.org/cgit/adwaita-icon-theme.git/commit/?id=fddcb93cab6d9f25505c015c58c596fd81f25d41

Comment 4 Rex Dieter 2014-10-28 13:54:15 UTC
works for me, though it's not clear to me now whether the icon scriptlets are needed for cursor-only themes or not.  I'd previously assumed yes, since the creation of the cursors/ subdir may update the modification time of the parent dir (and invalidate the cache)

Comment 5 Kalev Lember 2014-10-28 14:54:14 UTC
It probably isn't needed because adwaita-icon-theme has a hard dep on the new cursor theme package. This means that rpm always orders transactions so that adwaita-icon-theme gets installed last -- and runs its icon cache scriptlet then.

But if you want to add it, feel free to, I don't mind :)

Hopefully we'll be able to delete all the icon cache rpm script crazyness soon. I hear file triggers support is in the works and targeted for the next rpm release.

Comment 6 Kevin Kofler 2014-10-28 15:44:15 UTC
Your change works for us, but you probably want to add this to the adwaita-cursor-theme subpackage:
Conflicts: adwaita-icon-theme < 3.4.10-3

This ensures that, if the user has adwaita-icon-theme-3.4.10-2.fcNN or older installed and does a "yum install adwaita-cursor-theme", it will upgrade adwaita-icon-theme to the new version. Without the Conflicts, the user gets a file conflict instead.

Comment 7 Fedora Update System 2014-11-05 01:20:47 UTC
adwaita-icon-theme-3.14.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/adwaita-icon-theme-3.14.1-1.fc21

Comment 8 Fedora Update System 2014-11-05 19:24:42 UTC
Package adwaita-icon-theme-3.14.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing adwaita-icon-theme-3.14.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14299/adwaita-icon-theme-3.14.1-1.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-11-10 06:29:37 UTC
adwaita-icon-theme-3.14.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.