Bug 115751 - Missing language definition in Defaults.py
Summary: Missing language definition in Defaults.py
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-15 18:39 UTC by Zenon Panoussis
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 09:16:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zenon Panoussis 2004-02-15 18:39:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040126

Description of problem:

Traceback (most recent call last):
  File "/var/mailman/scripts/driver", line 87, in run_main
    main()
  File "/var/mailman/Mailman/Cgi/listinfo.py", line 61, in main
    list_listinfo(mlist, language)
  File "/var/mailman/Mailman/Cgi/listinfo.py", line 159, in list_listinfo
    replacements = mlist.GetStandardReplacements(lang)
  File "/var/mailman/Mailman/HTMLFormatter.py", line 379, in
GetStandardReplacements
    listlangs = self.GetLangSelectBox(lang).Format()
  File "/var/mailman/Mailman/HTMLFormatter.py", line 424, in
GetLangSelectBox
    legend = map(_, map(Utils.GetLanguageDescr, values))
  File "/var/mailman/Mailman/Utils.py", line 589, in GetLanguageDescr
    return mm_cfg.LC_DESCRIPTIONS[lang][0]
KeyError: pl

The problem turned out to be that Polish is not defined under
LC_DESCRIPTIONS in Defaults.py . Adding 
add_language('pl',   _('Polish'),              'iso-8859-2')
there solved it. 

You won't run into this as long as Polish is not enabled. 

Version-Release number of selected component (if applicable):
2.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Enable Polish for any mailing list.
2. Try to access that list's membersship management pages or try
3. bin/config_list -o outfile listname

Comment 1 Zenon Panoussis 2004-02-15 20:02:55 UTC
I checked. The problem is still there in mailman-2.1.1-5 (released as
a RH9 update last week), but has been fixed in mailman-2.1.2-2 in FC1. 

Comment 2 Florian La Roche 2004-06-06 09:16:54 UTC
I am closing this bug report since this item is fixed in the newest
rpm and we will not create further RHL9 update rpms.

Thanks for this bug-report,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.