Bug 115754 - up2date failure in FC2 test 1
Summary: up2date failure in FC2 test 1
Status: CLOSED DUPLICATE of bug 118039
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-15 18:58 UTC by Magnus Johansson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to error in obsolete list (384 bytes, patch)
2004-03-18 15:01 UTC, Charles Lopes
no flags Details | Diff

Description Magnus Johansson 2004-02-15 18:58:42 UTC
Description of problem:
up2date hangs when started from a non-privileged user

Version-Release number of selected component (if applicable):
Fedore Core 2 Test 1

How reproducible:
Always

Steps to Reproduce:
1. Login as a non-root user
2. up2date-nox -l
3.
  
Actual results:
You are attempting to run "up2date-nox" which requires administrative
privileges, but more information is needed in order to do so.
Password for root:
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-rawhide
using mirror: http://mirrors.kernel.org/fedora/core/development/i386/
 
Fetching Obsoletes list for channel: fedora-core-rawhide...
Traceback (most recent call last):
  File "/usr/sbin/up2date-nox", line 1267, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date-nox", line 797, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date-nox", line 1141, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 62, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 108, in
__findPackagesToUpdate
    self.availableUpdates = plist.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 574, in
getPackagesToInstall
    self.__findObsoletingPackages()
  File "/usr/share/rhn/up2date_client/packageList.py", line 454, in
__findObsoletingPackages
    if op & int(obsSense):
TypeError: int() argument must be a string or a number


Expected results:


Additional info:
When running this from a root-terminal, there are no problems.

Comment 1 Charles Lopes 2004-03-18 15:01:40 UTC
Created attachment 98651 [details]
Fix to error in obsolete list

Here's a simple fix to this problem

Comment 2 Adrian Likins 2004-03-22 21:03:59 UTC
fixed in cvs

*** This bug has been marked as a duplicate of 118039 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:01:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.