Bug 115764 - System-config-network should be started as root!
System-config-network should be started as root!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-15 16:23 EST by Kees
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 07:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kees 2004-02-15 16:23:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I just installed FC2 test 1. The kernel detects my network card fine. 
But I never got asked if I wanted to configure my network during the 
install. So I tried to do this manually by starting it from the menu.
It doesn't ask me for my root password, which it should!
Because it starts up and has only my normal user account permissions, 
it gives the following warnings (translated from Dutch):
system-config-network:

Error while copying //etc/hosts to
//etc/sysconfig/networking/profiles//default/hosts:
[Errno 13]: Access 
denied: '//etc/sysconfig/networking/profiles/default/hosts'!

After that the same error again, but for resolv.conf.

Then I got to the screen where I could configure my devices. But 
clicking any of the buttons (Activate, Deactivate, Configure) doesn't 
give any response.

If I type system-config-network as normal user on the gnome terminal. 
I got asked for my root password, and things work fine.



Version-Release number of selected component (if applicable):


How reproducible:
Always
Comment 1 Harald Hoyer 2004-02-16 04:06:55 EST
what menu entry did you start?
System/"Network Control" or Setup/"Network"
Comment 2 Kees 2004-02-16 06:25:07 EST
the hat 'start' button -> system tools -> network device controls
Comment 3 Harald Hoyer 2004-02-16 08:14:45 EST
This is for controling the devices.
You should use "System/Network" 

Note You need to log in before you can comment on or make changes to this bug.