Bug 115773 - (FS CIFS)cifs mounts die after awhile (Input/output error)
(FS CIFS)cifs mounts die after awhile (Input/output error)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-15 18:43 EST by Brian Krahmer
Modified: 2015-01-04 17:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 02:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Krahmer 2004-02-15 18:43:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
I am able to mount shares using mount.cifs just fine (from xp sp1
box).  After awhile, they seem to go away.  

# ls /mnt/e
ls: /mnt/e: Input/output error

I can immediately unmount and remount, and everything works again.  I
don't see any information in /var/log/messages...

Fedora Core release 1.90 (FC2 Test 1)



Version-Release number of selected component (if applicable):
samba-3.0.2-7.FC1

How reproducible:
Always

Steps to Reproduce:
1. mount a share
2. don't use it for awhile
3. access it
    

Additional info:
Comment 1 Jay Fenlason 2004-02-24 16:39:37 EST
This is a kernel bug, not a Samba bug.  I'm reassigning it to the
kernel team.
Comment 2 Matthew Sutton 2004-03-03 11:07:39 EST
I can mount cifs just fine from linux to windows 2000.  But in the 
middle of a large amount of files being copied the transfer rate goes 
to 0.  Then I start getting I/O errors.  Unmounting and Remounting 
does not fix the transfer problems only a restart.  Also if I leave 
the mount alone for a long time I get the I/O errors when I go to 
access the mount.

kernel-2.6.3-1.118
samba-3.0.2a-1

/var/log/meassges

smbd[1708]: [2004/03/03 09:58:44, 0] lib/util_sock.c:get_peer_addr
(952) 
Msmbd[1708]:   getpeername failed. Error was Transport endpoint is 
not connected 
smbd[1708]: [2004/03/03 09:58:44, 0] lib/util_sock.c:write_socket_data
(388) 
smbd[1708]:   write_socket_data: write failure. Error = Connection 
reset by peer 
smbd[1708]: [2004/03/03 09:58:44, 0] lib/util_sock.c:write_socket
(413) 
smbd[1708]:   write_socket: Error writing 4 bytes to socket 16: ERRNO 
= Connection reset by peer 
smbd[1708]: [2004/03/03 09:58:44, 0] lib/util_sock.c:send_smb(605) 
smbd[1708]:   Error writing 4 bytes to client. -1. (Connection reset 
by peer) 
Comment 3 Dave Jones 2004-11-29 04:39:57 EST
still a problem with the current update kernel ?
Comment 4 Mace Moneta 2004-11-29 08:44:44 EST
Yes; I have an FC3 machine (kernel-2.6.9-1.681_FC3) connecting to an FC2 machine
(kernel-2.6.9-1.6_FC2) to copy nightly backups.  I was using SMB, and tried
switching to CIFS.  Everything looked good, but the copies always failed about
halfway through (about 75MB copied).  Switching back to SMB (the only change)
and it works fine.  I added myself to the cc list for this bug just a couple of
days ago when searching for the cause.
Comment 5 Dave Jones 2005-04-21 02:34:28 EDT
if this still isn't fixed in the latest 2.6.11 update kernel, you'll probably
have more luck getting this fixed by reporting this to the upstream maintainer
Steve French <sfrench@samba.org>
Comment 6 Matthew Sutton 2005-04-21 10:21:22 EDT
Had so many problems switched to another distro where it works without a hitch.

Note You need to log in before you can comment on or make changes to this bug.