Bug 1157769 - JWS: VirtualHosts share pointer to mod_proxy configuration, results in: CreateBalancers behave the same with option 0 or 2
Summary: JWS: VirtualHosts share pointer to mod_proxy configuration, results in: Creat...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: JBoss Web Server 3
Classification: Retired
Component: mod_cluster
Version: 3.0.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: DR02
: 3.0.0
Assignee: Jean-frederic Clere
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On: 1157766
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-27 16:31 UTC by Michal Karm Babacek
Modified: 2015-08-20 22:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The directive `CreateBalancers` with the option `0` or `2` creates the balancers on all Apache HTTP Server virtual hosts. When using option `2`, it is expected that the balancers should be created on the main server only, and not on the virtual hosts. The cause of this issue is under investigation, and is expected to be resolved in a future release.
Clone Of: 1157766
Environment:
Last Closed: 2015-08-20 06:37:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker JWS-87 Major New JWS: VirtualHosts share pointer to mod_proxy configuration, results in: CreateBalancers behave the same with option 0 o... 2016-12-19 09:57:39 UTC
Red Hat One Jira Issue Tracker MODCLUSTER-430 Major Pull Request Sent CreateBalancers behave the same with option 0 or 2 2016-12-19 09:57:39 UTC

Description Michal Karm Babacek 2014-10-27 16:31:37 UTC
+++ This bug was initially created as a clone of Bug #1157766 +++

Please, read this description [1] and follow https://issues.jboss.org/browse/MODCLUSTER-430
for details.

This bug is deeply tricky and it has been around for quite some time. It's actually linked to Apache HTTP Server mod_proxy code integration.
We may even speculate whether it might be the root cause of some other mod_proxy integration issues, such as MODCLUSTER-391.


[1] https://github.com/modcluster/mod_cluster/pull/119#issue-45463288

Comment 1 Jean-frederic Clere 2015-01-20 16:40:01 UTC
Actually JWS3 upgrade to httpd-2.4.x so the BZ should be gone there.

Comment 2 Michal Karm Babacek 2015-01-26 17:06:39 UTC
The issue is httpd 2.4/2.2 agnostic, so it will not be gone in JWS3.

I shall revisit the approach outlined in https://github.com/modcluster/mod_cluster/pull/119#issuecomment-58634743 in the beginning of February; I agree that the current PR is too much "mod_proxy dependent".

Comment 4 Jean-frederic Clere 2015-02-26 16:41:01 UTC
Make it a known issue... It seems there isn't a good fix :-(
http://httpd.apache.org/docs/current/mod/mod_proxy.html#balancerinherit might be used instead.

Comment 5 Jean-frederic Clere 2015-02-26 16:43:02 UTC
Michal could test if BalancerInherit does something with mod_cluster?

Comment 7 Michal Karm Babacek 2015-03-17 10:27:41 UTC
Ad comment 5: I remember I tried that back in the day (BalancerInherit). It didn't affect the error, because servers share the same pointer, i.e. the configuration is not merely copied through.

IMHO, There is a good solution: One needs to call the mod_proxy config function in mod_cluster config phase (instead the current implementation-fragile mimicking that function) See my question regarding the improvement in: https://github.com/modcluster/mod_cluster/pull/119#issuecomment-58634743

Comment 8 Michal Karm Babacek 2015-04-23 07:14:21 UTC
Resetting devel_ack flag, because it had been based on comment 3 that was obsoleted by comment 7.

Comment 9 Michal Karm Babacek 2015-08-20 06:37:08 UTC
Moved: https://issues.jboss.org/browse/JWS-87


Note You need to log in before you can comment on or make changes to this bug.