Bug 1157819 - rubygem-staypuft: The default gateway isn't set on the right interface when among other NICs vlan tagged NIC is used.
Summary: rubygem-staypuft: The default gateway isn't set on the right interface when a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-27 18:31 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:04 UTC (History)
5 users (show)

Fixed In Version: rhel-osp-installer-0.4.5-3.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:04:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-27 18:31:57 UTC
rubygem-staypuft: The default gateway isn't set on the right interface when among other NICs vlan tagged NIC is used.


Environment:
rhel-osp-installer-0.4.5-2.el6ost.noarch
ruby193-rubygem-staypuft-0.4.10-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.31-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch


Steps to reproduce:
1. Install rhel-osp-installer and create nonHA neutron deployment.
2. Create subnet for public_api role
3. Create vlan tagged subnet for management + admin_api roles.
4. Obviously create subnets for external and tenant roles.
5. Deploy.

Result:
The default gateway isn't set on the interface with the public_api role. It is set to another nic (with management+admin_api roles).

Checking the configuration files for the NICs I see that while the NIC with public_api role (eno2) looks like this:
BOOTPROTO="none"
IPADDR="10.19.94.2"
NETMASK="255.255.255.0"
GATEWAY="10.19.94.254"
DEVICE="eno2"
HWADDR="c8:1f:66:c7:eb:61"
ONBOOT=yes
PEERROUTES=no
NM_CONTROLLED=no
PEERDNS=no
DEFROUTE=yes

* We see that DEFROUTE=yes exists and it's good.


The NIC with management and admin_api roles  (eno2.183) looks like this:
BOOTPROTO="none"
IPADDR="10.19.95.2"
NETMASK="255.255.255.0"
GATEWAY="10.19.95.254"
DEVICE="eno2.183"
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
VLAN=yes
NM_CONTROLLED=no


* While DEFROUTE=yes doesn't exist, there's also no line DEFROUTE=no.




Expected results:
The default gateway should be set on the NIC with the public_api role assigned.

Comment 1 Brad P. Crochet 2014-10-28 00:36:33 UTC
PR available: https://github.com/theforeman/foreman-installer-staypuft/pull/107

Comment 4 Alexander Chuzhoy 2014-10-30 19:55:31 UTC
Verified:
rhel-osp-installer-0.4.6-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.12-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.32-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch



The default gateway is set on the NIC with the public_api network traffic type, as expected. 
In all other NICs configuraion files, there's a line: DEFROUTE=no

Comment 6 errata-xmlrpc 2014-11-04 17:04:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.