Bug 1157858 - Slanted greyscale display on MGA G200e [102b:0522]
Summary: Slanted greyscale display on MGA G200e [102b:0522]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-27 21:29 UTC by Vasiliy Sharapov
Modified: 2018-07-10 14:13 UTC (History)
6 users (show)

Fixed In Version: xorg-x11-server-1.17.2-22.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:49:44 UTC


Attachments (Terms of Use)
Xorg log (48.50 KB, text/plain)
2014-10-27 21:29 UTC, Vasiliy Sharapov
no flags Details
video lspci (2.07 KB, text/plain)
2014-10-27 21:30 UTC, Vasiliy Sharapov
no flags Details
/var/log/messages (124.03 KB, text/plain)
2014-10-28 16:29 UTC, Vasiliy Sharapov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2293 normal SHIPPED_LIVE X.Org X11 server and drivers bug fix and enhancement update 2016-11-03 13:38:01 UTC

Description Vasiliy Sharapov 2014-10-27 21:29:45 UTC
Created attachment 951163 [details]
Xorg log

Description of problem:


Version-Release number of selected component (if applicable):
RHEL-7.1-20141024.1
kernel-3.10.0-193.el7.x86_64
xorg-x11-drv-modesetting-0.8.0-13.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL-7.1-20141024.1
2. Reboot

Actual results:
Video output is greyscale and slanted linto a parallelogram (cutoff area loops around on opposite side).

Expected results:
Normal video output.

Comment 1 Vasiliy Sharapov 2014-10-27 21:30:23 UTC
Created attachment 951164 [details]
video lspci

Comment 3 Vasiliy Sharapov 2014-10-28 16:29:49 UTC
Created attachment 951450 [details]
/var/log/messages

Comment 4 Dave Airlie 2014-10-29 06:42:21 UTC
what machine is this on, is it a directly connected monitor?

Comment 5 Vasiliy Sharapov 2014-10-29 10:53:07 UTC
(In reply to Dave Airlie from comment #4)
> what machine is this on, is it a directly connected monitor?

HP ProLiant ML110 G6
It has one VGA port.

Comment 6 Jérôme Glisse 2014-11-03 19:11:02 UTC
So i witnessed the issue and it is a simple pitch issue (or maybe a 24bit/32bit issue as iirc mga is the crazy hw that can do 24bit framebuffer).

Comment 7 Adam Jackson 2015-07-15 20:27:03 UTC
Reassign to xorg-x11-server, which has replaced -modesetting in 7.2.

Comment 8 Adam Jackson 2015-07-22 16:33:26 UTC
Do we still see this in 7.2?

Comment 9 Adam Jackson 2016-07-20 14:25:52 UTC
This ought to be fixed in 7.3, but does need testing.

Comment 10 Adam Jackson 2016-08-17 19:56:48 UTC
New modesetting shadow code should have fixed this, moving to MODIFIED.

Comment 13 errata-xmlrpc 2016-11-04 02:49:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2293.html


Note You need to log in before you can comment on or make changes to this bug.